F40 - Gnome Software checks for updates automatically, even when set to manual check

I’ve set Gnome Software preferences to do manual check for updates.

Yet each time I boot into the system, Gnome Software tries to check for flatpak updates from Fedora flatpak repos. A short while later, flatpak-system-helper does the same thing.

How do I disable this?

And why does Gnome Software preferences for manual/auto check not work, is there a hidden setting somewhere for flatpaks?