F37 no video in Gnome Videos (Totem)


i have a problem playing Videos in Totem on my HP laptop running a AMD Ryzen 7 5700U with Radeon (Integrated) Graphics, i can hear the sound but the screen is black when playing a video. I added the RPMfusion repos and followed this guide.

sudo dnf groupupdate multimedia --setop="install_weak_deps=False" --exclude=PackageKit-gstreamer-plugin
sudo dnf groupupdate sound-and-video
sudo dnf swap mesa-va-drivers mesa-va-drivers-freeworld
sudo dnf swap mesa-vdpau-drivers mesa-vdpau-drivers-freeworld

When i realized that this didn’t work i tried:

sudo dnf install gstreamer1-plugins-{bad-\*,good-\*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel

Still no luck though.

I then tried switching to xorg and it worked so i am guessing it is kind of related to wayland?

Thank you in advance!

I have exactly the same problem. Have you found a solution yet?
It works with VLC and Firefox also plays video. I think it is not a codec problem.

Nope still no solution. Afaik VLC brings their own codecs so it could be a codec issue.

I had a similar issue trying to play H.264-encoded MP4 videos (laptop with AMD integrated + Nvidia discrete) - black video display in Wayland, and in Xorg only half of the screen displayed video (and it was the upper-left half, if you divide the screen diagonally from lower-left to upper-right).

I installed Celluloid and it just worked, so I wonder if there’s just something with the GNOME Videos app?

Have you removed the ffmpeg-free from fedora and installed the ffmpeg package from rpmfusion?

1 Like

I am having the same issue after I updated my system last night. Something in the recent updates triggered the bug.

I am running F37, Wayland, and AMD open-source drivers. VLC & Firefox work, just not Gnome Videos.

Hmm, at least in my case, I don’t have ffmpeg-free (fedora repo) installed, but I do have ffmpeg (rpmfusion-free repo) installed?

I have installed ffmpeg from rpmfusion.
PS: I also have AMD CPU and graphics.

dnf info ffmpeg
Installierte Pakete
Name         : ffmpeg
Version      : 5.1.2
Release      : 3.fc37
Architektur  : x86_64
Größe        : 2.2 M
Quelle       : ffmpeg-5.1.2-3.fc37.src.rpm
Paketquelle  : @System
Aus Paketque : rpmfusion-free-updates-testing
Zusammenfass : Digital VCR and streaming server
URL          : http://ffmpeg.org/
Lizenz       : GPLv3+
Beschreibung : FFmpeg is a complete and free Internet live audio and video
             : broadcasting solution for Linux/Unix. It also includes a digital
             : VCR. It can encode in real time in many formats including MPEG1 audio
             : and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.

When I switch back with sudo dnf install ffmpeg-free --allowerasing, nothing runs anymore, because the corresponding codecs are missing.

Yes i am using the ffmpeg from rpmfusion not ffmpeg-free.

This looks to be a bug, 2155639 – mesa-22.3.1 breaks totem video

You can downgrade the mesa as a workaround.

sudo dnf downgrade mesa-dri-drivers
If you’re using rpmfusion (mesa-va-freeworld) you will want to add --exclude mesa-va-drivers

1 Like

The upstream bug looks to be, Commit ""radeonsi: enable glthread by default"" (d6fabe49cd72fb) causes a regression in gstreamer gtkglsink element (#7948) · Issues · Mesa / mesa · GitLab

You can run from a command line with, env mesa_glthread=false totem to work around.

1 Like

Interesting. I will test it when i am home in a few days. By the time it might be fixed already i guess.

I can confirm the workaround of ‘env mesa_githread=false totem’ allows totem to render video on my Nobara 36 system which has mesa 22.3.0.

I added export mesa_glthread=false to my ~/.bash_profile and it works great. Thank you.

Reported the bug: mesa_glthread=false totem is needed as a workaround for a black screen (#579) · Issues · GNOME / totem · GitLab