I am no longer able to play videos with Totem (and neither with some GStreamer based players)

Hello everyone, I have been running Fedora for a few years and this is the first time I have encountered a problem I am not able to sort on my own.

Last week I followed this guide: https://fedoraproject.org/wiki/Firefox_Hardware_acceleration in order to enable VA-API video decoding on my machine (AMD GPU) since I needed it in order to play VR games wirelessly. After I followed that guide I was able to game as intended.

However, today I noticed I am not able to play local videos any more using Totem (Gnome Video), no matter the format I throw at it: .mp4, .mkv, .mov… I keep getting either of these screens when opening the different files:

Screenshot from 2024-05-01 19-49-42

The first thing I tried was to try the Flatpak version of the app, which didn’t make any change, then I went back to the .rpm from the application store. I then tried other video players through Flatpak (gstreamer based ones since I have it installed already), and some of them manage to play some files, but most of the time they don’t work either.

I then tried to follow the same guide I did the other day but undoing all of the commands/changes there, but clearly I am missing something as videos don’t work still.

Can anyone help me? I don’t really know how to diagnose this or how to look for the information I need.

It is my understanding that the nvidia-vaapi-driver package has been obsoleted with the newer nvidia driver packages.
If you installed that as shown here Install nvidia-vaapi-driver from RPM Fusion repository non-free. Don't use Fedora provided libva-vdpau-driver package as it's old and broken. in your linked instructions then that package could very well be part of the problem. Try removing it to see if there is a change.

The OP suggests its an AMD GPU, so the nvidia-vaapi-driver probably isn’t going to work here.

I’m not sure on why video playback with Totem wouldn’t work, but I’ve used mpv on GNOME and even Plasma 6 for a bit because their Dragon Player was over-saturating stuff and broken.

Totem in the past didn’t playback something ideally for me but mpv was fine and was lighter so that had me switch. I find debugging and hardware-acceleration easier with it, and I like that it’s basic; it’s like a no-nonsense light version of VLC. HW acceleration VAAPI VDPAU GPU anything should work fine with it, and I recommend it.

Never knew that existed, but why would that be preferred over VDPAU?

1 Like

I think I solved the issue, somehow. I am not sure which of these things was the solution, or if it was a combination of both, but I did:

  • Uninstall the flatpak of Gnome Videos (Totem)
  • removed the cache files for both totem and gstreamer:
rm -rf ~/.cache/totem
rm -rf ~/.cache/gstreamer-1.0
  • Install the native package of Gnome VIdeos (Totem)

If anyone has an explanation of why this worked, I am curious to learn.

1 Like

that is so true.

1 Like