F36 KDE: CTRL+SHIFT+U<code point> does not work


In Fedora 35 KDE I used to be able to type unicode characters with the help of CTRL+SHIFT+U<code point>. Since installing Fedora 36 KDE this key combination doesn’t do much. I often typed the em-dash (—), for example, using CTRL+SHIFT+U 2014 SPACE. Since Fedora 36 applications seem to ignore the keycombo and just print out the number 2014.

As far as I can tell there are no error messages. I don’t know how to troubleshoot or fix this issue. Any suggestions?

1 Like

Hi @q8dkjt5rqw3bxt , welcome to the community!

Please take a look at the introductory posts in the #start-here category if you’ve not had a chance yet.

Can you please run


and see what it says there for the unicode point?

1 Like

Thanks! :smiley:

Well, it says <Control><Shift>u.

1 Like

That should be working then. Is ibus daemon etc working? These are all the processes I have running on my system—it’s Gnome on X, but should be similar to what you need on KDE:

$ pgrep -fa ibus
16524 /usr/bin/ibus-daemon --panel disable --xim
16614 /usr/libexec/ibus-dconf
16615 /usr/libexec/ibus-extension-gtk3
16620 /usr/libexec/ibus-x11 --kill-daemon
16711 /usr/libexec/ibus-portal
16902 /usr/libexec/ibus-engine-simple
17775 /usr/libexec/ibus-engine-m17n --ibus
17776 /usr/bin/python3 /usr/share/ibus-typing-booster/engine/main.py --ibus


I found some info on the Arch wiki suggesting that Ibus needs to be enabled on KDE manually. Not really sure how up to date this is because I don’t use KDE, but worth a try?


I have some more information. First, the ibus daemon was and is working:

$ pgrep -fa ibus
1485 /usr/bin/ibus-daemon -r --xim
1499 /usr/libexec/ibus-dconf
1501 /usr/libexec/ibus-ui-gtk3
1503 /usr/libexec/ibus-extension-gtk3
1507 /usr/libexec/ibus-x11 --kill-daemon
1510 /usr/libexec/ibus-portal

And I also tried to add the environment variables the Arch-wiki suggested. That didn’t improve anything, unfortunately.

However, I did find out it (CTRL+SHIFT+U) does work when logged into a Plasma (X11) session, but not Plasma (Wayland).

Another thing I noticed, which may not be related to this at all, Deadbeef’s tray icon does not show up on Wayland (which it did on F35), but does on X11. Elisa’s tray icon shows up on both X11 and Wayland.

It’s a Wayland issue now? If so, how do I find out more?

1 Like

Certainly appears to be, and I suspect it should have a bug filed against wayland if not already done.

1 Like

In the meanwhile I have found ibus/Wayland related bug reports, such as:

I’ll mark this issue as solved here and hope this bug, or lack of proper support (?), gets resolved quickly.

@FranciscoD: without your help I would have had no idea I had to look into ibus related stuff. Thank you. :smiley: