F35 Kinoite update error

Since rebasing to F35, this error occurs while updating.
I’m not sure the best way to resolve this.
Can someone suggest a fix?

Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora rpmfusion-free-updates rpmfusion-free rpmfusion-nonfree-updates rpmfusion-nonfree fedora-modular updates-modular phracek-PyCharm rpmfusion-nonfree-nvidia-driver updates-archive
Updating metadata for ‘rpmfusion-nonfree-nvidia-driver’… done

error: Updating rpm-md repo ‘rpmfusion-nonfree-nvidia-driver’: Failed to download gpg key for repo ‘rpmfusion-nonfree-nvidia-driver’: Curl error (37): Couldn’t read a file:// file for file:///usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-35 [Couldn’t open file /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-35]

Does this file doesn’t really exist?

ls -la /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-35

You might want to try removing all your layered packages (via rpm-ostree reset), updating and then re-installing them and use Simplifying updates for RPM Fusion packages (and other packages shipping their own RPM repos) for RPM-Fusion repos.

I have tried the rpm-ostree reset and updating , re-installing packages but still the same error appears.
The more I research this I realise that it is looking to download gpg keys into //usr/share/distribution - folder which doesn’t exist.
I even tried rebasing back to standard silverblue and same error.
Any ideas ?

In order for us to be able to help you, you need to provide the exact commands you are trying, in which order, and the error messages. rpm-ostree status output at each step will also help.

I have rpmfusion for Silverblue enabled and some packages installed.

The directory /usr/share/distr* does not exist. The one I am using looks like this:

● fedora:fedora/35/x86_64/updates/kinoite
Version: 35.20220208.0 (2022-02-08T00:50:14Z)
BaseCommit: 024a81dfdb94dc1dc8a38f94a44cfc7289c57df71e4cb07852400f142d843ffe
GPGSignature: Valid signature by 787EA6AE1147EEE56C40B30CDB4639719867C58F
LayeredPackages: ffmpegthumbs kakoune kde-connect kvantum openssl zsh
LocalPackages: rpmfusion-free-release-35-1.noarch rpmfusion-nonfree-release-35-1.noarch
Pinned: yes

Removing the two rpmfusion-nonfree .repo files (steam and nvidia) makes the rpm-ostree commands work again.

Pastebin of rpmfusion-nonfree-nvidia-driver.repo: https://p.teknik.io/heg4c

Pastebin of rpmfusion-nonfree-nvidia-steam.repo: https://p.teknik.io/E28G7

Removing the .repo files and then doing sudo rpm-ostree refresh-md seems to have solved the issue, I never used these repos in the firs tplace.