Errors when updating Fedora Kinoite

Hello,
again I get errors when trying to update. I have no idea why this keeps happening. Is it just me who gets these errors or are there more users of immutable Fedora systems who get them?

This is some info I get:

rpm-ostree status
State: idle
Deployments:
● fedora:fedora/40/x86_64/kinoite
                  Version: 40.20240622.0 (2024-06-22T02:00:40Z)
               BaseCommit: ba6c8e3348b57cd0efca56289147f348f53cc923143e0cfafce2ec7208201771
             GPGSignature: Valid signature by 115DF9AEF857853EE8445D0A0727707EA15B79CC
          LayeredPackages: akmod-nvidia akmods conky qemu qemu-kvm rpmfusion-free-release rpmfusion-nonfree-release virt-manager xorg-x11-drv-nvidia-cuda yt-dlp

Below are the errors I received in Discover when I started the update. They are the same when I type rpm-ostree upgrade in the terminal.

rpm-ostree transaction failed with:
error: Could not depsolve transaction; 2 problems detected:
 Problem 1: package akmods-0.5.8-8.fc40.noarch from fedora requires gcc, but none of the providers can be installed
  - package gcc-14.1.1-5.fc40.x86_64 from updates requires cpp = 14.1.1-5.fc40, but none of the providers can be installed
  - package gcc-14.0.1-0.15.fc40.x86_64 from fedora requires cpp = 14.0.1-0.15.fc40, but none of the providers can be installed
  - package gcc-14.1.1-1.fc40.x86_64 from updates-archive requires cpp = 14.1.1-1.fc40, but none of the providers can be installed
  - cannot install both cpp-14.1.1-5.fc40.x86_64 from updates and cpp-14.1.1-6.fc40.x86_64 from @System
  - cannot install both cpp-14.0.1-0.15.fc40.x86_64 from fedora and cpp-14.1.1-6.fc40.x86_64 from @System
  - cannot install both cpp-14.1.1-1.fc40.x86_64 from updates-archive and cpp-14.1.1-6.fc40.x86_64 from @System
  - conflicting requests
 Problem 2: conflicting requests
  - package akmod-nvidia-3:550.90.07-1.fc40.x86_64 from rpmfusion-nonfree-updates requires akmods, but none of the providers can be installed
  - package akmod-nvidia-3:550.67-1.fc40.x86_64 from rpmfusion-nonfree requires akmods, but none of the providers can be installed
  - package akmods-0.5.8-8.fc40.noarch from fedora requires gcc, but none of the providers can be installed
  - package gcc-14.1.1-5.fc40.x86_64 from updates requires libgomp = 14.1.1-5.fc40, but none of the providers can be installed
  - package gcc-14.0.1-0.15.fc40.x86_64 from fedora requires libgomp = 14.0.1-0.15.fc40, but none of the providers can be installed
  - libgomp-14.1.1-5.fc40.i686 from updates  does not belong to a distupgrade repository
  - libgomp-14.0.1-0.15.fc40.i686 from fedora  does not belong to a distupgrade repository
  - package gcc-14.1.1-1.fc40.x86_64 from updates-archive requires libgomp = 14.1.1-1.fc40, but none of the providers can be installed
  - cannot install both libgomp-14.1.1-5.fc40.x86_64 from updates and libgomp-14.1.1-6.fc40.x86_64 from @System
  - cannot install both libgomp-14.0.1-0.15.fc40.x86_64 from fedora and libgomp-14.1.1-6.fc40.x86_64 from @System
  - cannot install both libgomp-14.1.1-1.fc40.x86_64 from updates-archive and libgomp-14.1.1-6.fc40.x86_64 from @System

Have I installed something the wrong way, did I install wrong packages, what can cause this?
Slowly I am thinking of moving away from Kinoite and go back to the regular Fedora 40-KDE because I’m not getting it and it is not my OS, or something is wrong in the OS.
I did sent the errors to https://pagure.io/fedora-kde/SIG/issues as well. I saw a button to do this in Discover.
I sure hope this gets fixed because apart from the updates (caused either by me or by the system), Kinoite is a great distro.

This will inevitably happen from time to time when you layer packages and the dependency resolution can not succeed. Waiting for the next compose tomorrow should resolve it.

See:

Hello Timothée, thank you for your answer. But that means that more people have this same problem when doing updates, right? When I ask in the forum about it nobody answers Yes, I have the same. Strange.
Well, I did update yesterday evening and it went smooth again, also today there was a new system update (date 0624) and it went fine.

I don’t understand how it all works with layering programs but as long as it works I am happy.
Thank you again.

Do you have to layer many packages? This is where the conflicts arise from.

Hello, how else can I install the programs which I have layered now? They are not available as flatpacks so, as far as I know, this is the only way?

Podman, toolbox, Docker. What are the programs you have layered?

I have layered:
akmod-nvidia akmods conky qemu qemu-kvm rpmfusion-free-release rpmfusion-nonfree-release virt-manager xorg-x11-drv-nvidia-cuda yt-dlp

I never thought of using toolboxes, I really have to look into that. Any good website where I can find helpful information?

i think this needs to be layered.

Not sure about conky. . . It might run in a toolbox :thinking: Other than that, you really don’t have much else. Sometime the repo either lags behind/ahead and causes these conflicts. Waiting a day or waiting for another update fixes the issues.

The issues you have are likely due to the NVIDIA kernel module package.

This is bound to happen as the kernel module comes from RPM Fusion and it needs time to be updated for each new kernel release.

If you don’t want to have those issues, I recommend using Universal Blue:

Qemu does work in toolbox, I just tried that. What I don’t know yet is conky, but I will try it.

What I don’t know is how to handle the toolbox itself and how to handle programs which are installed in the toolbox. Can I let them start automatically at boot, can I start them from outside the toolbox, or do I need to enter it first?
All things I need to learn.

@ Timothée Ravier Yes, I thought already it could be caused by the Nvidia driver, it wouldn’t be the first time.

Thanks, I will try to find some documentation about toolbox and start learning.

1 Like

Here is a link of some cool things I did with images and toolbox for some development isolation :

and a Dev Env :