Errors when trying to update from GNOME Software

The update service is a mess for me…
In the past months, every 2-3 days I keep getting 503 errors or certificate errors when trying to install updates.
The problems usually persist for a day or so…
For example, here’s the error I have since yesterday for org.fedoraproject.Platform - f32:
F32 update error
I live in Eastern Europe. Maybe it’s a mirroring problem.

2 Likes

I’m in Germany and have been getting errors like this when updating Fedora flatpaks. I disabled Fedora so I could update the rest:

flatpak remote-modify fedora --disable

And — probably related — today when I did a podman system reset and then tried to download a new toolbox, it didn’t work. I kept getting 503 errors there too.

After running the toolbox create command around 20 times, it finally downloaded everything needed to create a F32 toolbox at least. (Otherwise, I couldn’t work today. “Fun”.)

Where’s the right place to report Fedora server issues?

1 Like

It took me several minutes and tries to sign in with my FAS ID to this site today, and I am in Canada. Emphasis on minutes…

24 hours later… org.fedoraproject.Platform - f32 still does not install, now I get an error saying: Checksum digest did not match.

We are now tracking this issue at https://pagure.io/fedora-infrastructure/issue/9210 sorry for the inconvenience.

1 Like

Bug was closed as duplicate. Here’s the issue to track:
https://pagure.io/fedora-infrastructure/issue/9177

1 Like

I hope that whatever happened, people figure it out and put something in place to prevent this from happening again.

Not being able to have a toolbox to work in (after a poorly timed podman system reset) almost messed up my whole workday. (Thankfully, I was able to get it working by running the command a few dozen times in a row and count on checksums to have the right image downloaded.)

1 Like

I was doing some testing with toolbox last days and I got the same error again and again, so I create a mirror of the images here:
https://hub.docker.com/r/juanje/fedora-toolbox

I tried a few times and it worked fine every time. It’s a temporary fix (until the official registry get fix), but if anyone need to pull the toolbox image and have troubles, feel free to use it:

[user@host ~]$ toolbox create --image docker.io/juanje/fedora-toolbox:32
[user@host ~]$ toolbox enter
⬢[user@toolbox ~]$ 

I was able to update all of my Flatpaks, toolbox, and rpm-ostree just a few minutes ago. I was getting worried for a day or two but it’s nice to be back up again.

1 Like

I am getting a new error: The name is not activatable.
It started 6-7 days ago.

A month later, it is still happening. Can someone look into this?

I saw this error today too. But it does not show up all the time so I don’t know how to reproduce it and I don’t see anything is broken AFAICT. I usually just wait awhile to see if a new update fixes it. You can submit a bug to Gnome.org if it is not already being worked on there.

Maybe related to this issue https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1104.