Error when mounting WSL2 ext4.vhdx image in F36


I tried for the first time to mount the WSL2 disk image of a windows 10 (dualboot) and I was surprised that it did not work.
This is the command I used:

sudo guestmount -o allow_other --add /run/media/username/Windows/Users/Username/AppData/Local/Packages/CanonicalGroupLimited.UbuntuonWindows_79rhkp1fndgsc/LocalState/ext4.vhdx -i /mnt/

libguestfs: error: could not create appliance through libvirt.

Try running qemu directly without libvirt using this environment variable:

Original error from libvirt: unsupported configuration: unknown driver format value 'vhdx' [code=67 int1=-1]

Is it possible that this is a new bug ? because It seems libguestfs is supporting the vhdx format since quite some time.
Or am I doing something wrong here ?

For info, the ext4.vdhx image is on the bitlocker encrypted partition of windows10.
But F36 could without any issue decrypt it and mount it in a very user friendly manner via nautilus.
this is the output of file:

file ext4.vhdx 
ext4.vhdx: Microsoft Disk Image eXtended, by Microsoft Windows 10.0.18865.0, sequence 0x94, NO Log Signature; region, 2 entries, id BAT, at 0x300000, Required 1, id Metadata, at 0x200000, Required 1

If you have any advice,

thank you

Hi, came here to know how to mount wsl disk.

So I ran your command above and get the same error. But in the error message it says to try with “export LIBGUESTFS_BACKEND=direct”.

So I tried and it works!