Error running steam

Hi there, I’ve been trying to get steam to run on fedora 32 and failing miserably. I keep getting You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

When I try to do a dnf install of the relevant package, I get Package glibc-2.31-4.fc32.i686 is already installed.

I’ve tried everything I can think of, which isn’t a lot, but am totally stuck.

This is a new install of F32 as my hard disc crashed fatally and beyond repair. The previous version was an F28 install that had been continuously updated, and although I only installed steam at F31, it worked when I got to F32. Then my disc crashed, and now can’t play. :frowning:

Dave

2 Likes

Post the output:

dnf -q repolist; rpm -q steam

`[dave@centaur ~]$ dnf -q repolist; rpm -q steam

repo id repo name
code Visual Studio Code
fedora Fedora 32 - x86_64
fedora-cisco-openh264 Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 32 - x86_64
rpmfusion-free RPM Fusion for Fedora 32 - Free
rpmfusion-free-tainted RPM Fusion for Fedora 32 - Free tainted
rpmfusion-free-updates RPM Fusion for Fedora 32 - Free - Updates
rpmfusion-nonfree RPM Fusion for Fedora 32 - Nonfree
rpmfusion-nonfree-updates RPM Fusion for Fedora 32 - Nonfree - Updates
updates Fedora 32 - x86_64 - Updates
updates-modular Fedora Modular 32 - x86_64 - Updates
virtualbox Fedora 32 - x86_64 - VirtualBox
steam-1.0.0.64-1.fc32.i686`

1 Like

How did you install steam?

sudo dnf -y install steam

IIRC.

I have tried uninstalling and re-installing it. Both through dnf reinstall and dnf remove followed by dnf install

Dave

Perform Steam installation reset:
https://wiki.archlinux.org/index.php/Steam/Troubleshooting#Missing_libc
Post the output if the issue persists.

3 Likes

You sir, are an absolute hero!

Thank you, it all now works.

Dave

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.