Steam not working on Fedora 30

Hi Everyone, I am hoping this is the right place to get some advise, I am tring to get steam running under fedora 30 but I keep getting the error -

You are missing the following 32-bit libraries, and Steam may not run:
and then
Failed to load - dlerror(): /lib/ file too short

LibGL appears to be installed, I even reinstalled and get the same error any one know the fix ?

Hello @Loupy! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Sorry, but I don’t use Steam :man_shrugging: however these two posts could be of help to you?

Steam no longer works (flatpak, nvidia graphics card)

Problem: glib-networking-2.60.1-2.fc30.i686 has inferior architecture

Let us know!

Thanks for the quick response!! Alas neither of those fixed my issue so far.

Wait I take that back! Installing steam via flatpack worked :slight_smile: thank you so much for your help!

I’m glad that it’s working, but in case you decide to use the regular package (from rpmfusion) or someone else does, here’s what I would have posted:

This looks like a dependency issue. Steam is a 32-bit program, so it requires 32-bit libraries. You seem to be missing glibc.i686. The same could apply for, but I do know that it’s just meant to be a symlink to the actual library (for me, The “file is too short” error suggests that it either isn’t following the symlink, which could be the case if the package isn’t installed (not likely), or that you don’t have the 32-bit version of the package, so the symlink in /lib directs to the library in /lib64 (more likely). I also know that both the library and the symlink are provided by libglvnd-glx.i686.

You can check dependencies with rpm -qR or rpm -qpR , but dnf should have automated this. Did you install an rpm directly? If you got it from rpmfusion or another repo, dnf should have pulled in all dependencies.

Flatpak maintains its own libraries, so using the flatpak would resolve this issue, as you observed.