Error: couldn’t switch to requested monitor resolution

Hello, I have a problem launching games through Steam and Heroic Launcher.
When launching any game through Heroic/Steam/Bottles Flatpak, the error “Error: couldn’t switch to requested monitor resolution” appears. Heroic/Steam Native (rpm) games launch normally. Or you can run vulkaninfo and the problem will disappear until the next reboot.

It might be useful, this is right after loading the OS

yanex@fedora:~$ lsmod | grep -iE "nvidia|nouveau"
nvidia_drm            135168  0
nvidia_modeset       1617920  1 nvidia_drm
nvidia_uvm           6815744  0
nvidia              61018112  7 nvidia_uvm,nvidia_modeset
video                  81920  3 xe,i915,nvidia_modeset

Other distributions (Arch and OpenSUSE) do not have this problem.

GPU: NVIDIA GeForce RTX 3060 Laptop GPU
Driver: 555.58.02
OS: Fedora 40 KDE (Wayland)

ok there’s a lot here we need to clear up. . .

  • Are you saying this is a Flatpak issues?
  • When you say the rpm’s don’t have issues do you mean, Steam/Heroic Launcher .rpm and not the game’s themselves?
  • Have you tried reaching out to Bottles, Heroic, Steam Issues tracker to see if this is something they have seen?
  • Launch the game from a terminal and see if you can retireve any error messages from the output?
  • Is your machine up to date and you have all the runtimes you need ? especially the one for Nvidia.

I’m not sure, but most likely not.

Games run normally through native versions of Steam and Heroic, unlike their Flatpak versions (I hope I explained it clearly…)

I tried, tickets have been hanging since April 30th

I didn’t find anything useful there, but…

I think so, actually, this is a clean install done today.

Maybe this will be useful, although I’m not sure:

Also, a similar post was already here, from another person:

Please post the output of

  • inxi -Fzxx
  • dnf list installed \*nvidia\*

1 thing you can try is to downgrade the driver to 550.XXX.X

But let’s see the hardware first.

From your logs:

ERROR: Unable to create DisplayServer, all display drivers failed.
DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.

We’ll see what version of Mesa you have after you produce these results for us.

yanex@fedora:~$ inxi -Fzxx
  Kernel: 6.9.7-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: KDE Plasma v: 6.1.1 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
  Type: Laptop System: HP product: Victus by HP Laptop v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 88F8 v: 88.58 serial: <superuser required>
    part-nu: 4R881EA#A2Q UEFI: AMI v: F.26 date: 04/19/2024
  ID-1: BAT0 charge: 52.4 Wh (100.0%) condition: 52.4/70.1 Wh (74.7%)
    volts: 17.1 min: 15.4 model: HP Primary serial: <filter> status: full
  Info: 6-core model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 480 KiB L2: 7.5 MiB L3: 12 MiB
  Speed (MHz): avg: 853 high: 1057 min/max: 800/4500 cores: 1: 800 2: 1057
    3: 800 4: 800 5: 989 6: 800 7: 800 8: 800 9: 800 10: 800 11: 1000 12: 800
    bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a68
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
    vendor: Hewlett-Packard driver: nvidia v: 555.58.02 arch: Ampere ports:
    active: none empty: DP-2,HDMI-A-1 bus-ID: 0000:01:00.0 chip-ID: 10de:2520
  Device-3: Luxvisions Innotech HP Wide Vision HD Camera driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-6:4 chip-ID: 30c9:000e
  Display: wayland server: v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: N/A display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: iris
    device: 3 drv: swrast surfaceless: drv: nvidia wayland: drv: iris x11:
    drv: iris inactive: gbm,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.2 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics (TGL GT1)
    device-ID: 8086:9a68 display-ID: :0.0
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: N/A device-ID: 8086:9a68 device: 1
    type: discrete-gpu driver: N/A device-ID: 10de:2520 device: 2 type: cpu
    driver: N/A device-ID: 10005:0000
  Device-1: Intel Tiger Lake-H HD Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:43c8
  Device-2: NVIDIA GA106 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228e
  Device-3: fifine Microphones Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 bus-ID: 3-1:2 chip-ID: 3142:00a8
  API: ALSA v: k6.9.7-200.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:43f0
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000
    bus-ID: 0000:02:00.0 chip-ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-14:5 chip-ID: 8087:0026
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b
  Local Storage: total: 953.87 GiB used: 201.71 GiB (21.1%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL21T0HCLR-00BH1
    size: 953.87 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 44.9 C
  ID-1: / size: 60 GiB used: 19.47 GiB (32.5%) fs: btrfs dev: /dev/nvme0n1p9
  ID-2: /boot/efi size: 511 MiB used: 24 MiB (4.7%) fs: vfat
    dev: /dev/nvme0n1p6
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A
  Fan Speeds (rpm): cpu: 2200 fan-2: 2393
  Memory: total: 16 GiB note: est. available: 15.25 GiB used: 2.89 GiB (18.9%)
  Processes: 385 Power: uptime: 2m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 29 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34
akmod-nvidia.x86_64                                  3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
kmod-nvidia-6.9.7-200.fc40.x86_64.x86_64             3:555.58.02-1.fc40             @@commandline             
nvidia-gpu-firmware.noarch                           20240610-1.fc40                @updates                  
nvidia-modprobe.x86_64                               3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                           3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
nvidia-settings.x86_64                               3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                           3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                      3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                 3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                   3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                      3:555.58.02-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                     3:555.58.02-1.fc40             @rpmfusion-nonfree-updates	

I think that there is no point in downgrading the driver version, because the 550 had exactly the same problem back in April