Recent update broke games

Updates accumulated for 1 or 2 weeks and I decided to update yersteryday. The next day most of my games stopped working. I suspect it’s something to do with vulkan since trying tf2 gives me “Failed to create SDL window: Installed Vulkan doesn’t implement the VK_KHR_surface extension” and Detroit Become Human gives me “Unable to find suitable graphics card with Vulkan 1.1 support”. I run most games in Bottle but since this issue also happens in steam i’m thinking it’s a system issue.
My system is up to date.

The thing is that i don’t know which package caused the things to break as I haven’t looked at the pending updates.

System Details Report


Report details

  • Date generated: 2024-06-15 14:01:10

Hardware Information:

  • Hardware Model: ASUS TUF GAMING B550-PLUS WIFI II
  • Memory: 32.0 GiB
  • Processor: AMD Ryzen™ 5 5600X × 12
  • Graphics: AMD Radeon™ RX 7800 XT
  • Disk Capacity: 1.0 TB

Software Information:

  • Firmware Version: 3404
  • OS Name: Fedora Linux 40 (Workstation Edition)
  • OS Build: (null)
  • OS Type: 64-bit
  • GNOME Version: 46
  • Windowing System: Wayland
  • Kernel Version: Linux 6.8.11-300.fc40.x86_64

Additional info: I have two rollbacks but the same issue on all of them. I run steam and bottles in flatpak

Have you tried sudo flatpak repair command to check if any file is corrupted?

Rolling back your system update does not fix the issue because Flatpak apps use their own Flatpak runtime. Instead, you may follow this guide to rollback (downgrade) them:

Tried two games which have native linux builds and flatpaks and it’s a flatpak issue after all since the fedora packages work.

Tried to downgrade a few runtimes using Warehouse, but the flatpaks still didn’t work. Installed the fedora bottles package in the mean time and it’s all good.

Sorry for off topic issue and thanks for setting me in the right direction :slight_smile:

1 Like