Duplicates finder in Fedora

can anyone recommend a tool that scans my home folder for duplicates?

I have tried a few but none of them work.

Can’t believe we don’t have a working tool in our repos…

  • edit: and then there is Czkawka (Czkawka | Flathub) on flathub, which doesn’t work either. I used flatseal to grant permission scanning my home dir but still the software hangs in the initial stage at 0,0% for over an hour. Piece of ----.
2 Likes

I found, but have never tried, the following:

1 Like

I’ll give Rdfind a try.

that rpm didn’t work (wasn’t able to start the program), despite matching the requested pyton version. (moreover, I need software from an offical repo - I have no time to manually update packages).

EDIT: rdfindworks fine - I’d prefer a GUI software for that purpose, but ok, I can live without.

EDIT2: after restarting my machine, I am able to use Czkawka (Flathub—An app store and build service for Linux) - this tool looks promising too. I has a lot of options and features.

1 Like

Is anyone still using rdfind? I just noticed that it has been retired and is not available in Fedora 38. Had it on my laptop but it has been a long time since I’ve been using it. Still, if someone needs it we/I can unretire and take care of it, it seems like low maintenance to me. (Not sure why it was retired in the first place though.)

2 Likes

There is jdupes in repos, which claims to be better and faster than fdupes.

I have not used any of the other tools to compare, but jdupes seems fast to me (scanned ~300k files in my home folder in just over 2 minutes), and easy to use with sensible options.

rdfind was retired after 6 weeks orphaned and nobody claimed it. Not sure why it was orphaned, either maintainer(s) were inactive or didn’t want it any more. See here for claiming retired packages.

1 Like

I started using detwinner (linked above), and I am actually quite happy, especially on how I can select a scheme after which duplicates are removed.

I would like to install rdfind.

1 Like

Requested unretirement, if anyone here wants to co/maintain let me know!

2 Likes

I also found Czkawka (pronounced tch•kav•ka (IPA: [ˈʧ̑kafka]), “hiccup” in Polish) (the gif below is from the project’s GitHub repo) :

Czkawka usage example

There are various ways it can be installed, but the easiest is as a Flatpak by running:

flatpak install flathub com.github.qarmin.czkawka

or as an rpm by running the following commands:

sudo yum install gtk4-devel glib2-devel
sudo dnf -y install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
sudo dnf -y install https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
sudo dnf -y install ffmpeg

It seems to be a nice tool and I think it’s worth a try.

Good news: rdfind has been reinstated by someone else and is available again on Fedora :party:

(I tried to revive it quickly but it was too old and needed a new review process and with that landed somewhere at the bottom of my todo list)