Where did FSLint go?

Where did FSLint go? I installed it a decade ago and have been faithfully upgrading my fedora instance all this time. Go to use it today, and it’s icon shows up in gnome’s app list but I click it and it never says hello.

I run from cli and see some glade/gtk dependacy is missing.

I tried using a “snap version” of it but that runs like crap, font’s render as boxes, and what’s snap about anyway.

I uninstall my old version with dnf, and go to reinstall it and its not in the repo, no results for dnf search fslint dnf search fs-lint, or dnf whatprovides ‘*/fslint’

What gives? It was such a simple useful tool. Where did it go? Where’s the right place to go for a log of what happened/why it was removed?

Well I think I found out why:

That’s really too bad. There was NOTHING wrong with fslint. I’d happily have kept the old pygtk2 files and their dependancies on disk just to keep fslint working.

After a bit of research I found DupeGuru and Czkawka. The readme of Czkawka compared speed between it, fslint, and DupeGuru and Czkawka came out ahead, so I tried it.

git clone GitHub - qarmin/czkawka: Multi functional app to find duplicates, empty folders, similar images etc.
cd czkawka
sudo dnf install gtk3-devel glib2-devel alsa-lib-devel
cargo run --release --bin czkawka_gui

A little nuts the commandline to run this tool, but I’ll make a .desktop out of it and be done with it i guess.

1 Like

You should be able to install czkawka from Flatpak, which I would think has the desktop file already.