Does the Geary email client need firewall or SELinux permissions?

Hi all, I recently started using Fedora. By now, I have tried a couple of times to set up Geary as the email client for my gmail account, since it is the client that Fedora comes with.
Yet it does not work:

  • Right from the first screen, “select an email provider”, no provider appears.
  • And if I click “Add” and input my account details, and click “Create”, the following banner appears on top:

“Account not created. Could not connect, check your network”.

  • I also tried out, unsuccessfully, the flathub version, which is favored by Geary
  • And, I went through the Geary documentation, which claims that their latest version needs no fiddling with gmail settings.
  • And I went through their tiny Troubleshooting section.

My internet is working fine, and I can use the web version. I also use the Spike client on Windows, without a problem.
I know Fedora uses SELinux, which greatly restricts network connections. So I was wondering if this has something to do with it, or if it is the firewall.
If so, how could I fix this?
If not, what else could it be (and what should I do then)?
Finally, I am wondering if I should just try another client instead of breaking my head. So, would you recommend a different email client instead? Which one?
Thank you all for your help

I used Geary with and never had a problem. I used it with Silverblue. Geary set up the account and worked without any issues. Maybe this is a Gmail issue, not a Fedora or Geary issue?

As an alternative you could try Thunderbird or Blue Mail.

I just tried using BlueMail. The Google “Do you authorize …” webpage appeared and I accepted, and all good, but then, Blue Mail and Gmail just get stuck trying to connect with each other? I guess?
I guess Geary was not the problem, and neither Google? I’m leaning towards a firewall/SELinux obstacle.
Do you use any specific settings for either?

I didn’t do anything other than enter my account info/password. I didn’t mess with any firewall settings. Maybe try creating an Outlook account and see if it works? If it does, then you know Google is the problem.

App passwords should not be necessary.
@jerry-mcguire Did you follow Geary’s directions for connecting to Gmail?

1 Like

Yes, and there is no need to do any fiddling according to them:

If you are running an up-to-date version of Geary, simply add your GMail account using the Online Accounts panel of GNOME Settings, and no further action needs to be taken by you.

OMG, I’m so sorry. I did not read carefully. I went to the “settings” for all the computer, and set my google account there. Then Geary worked indeed! My apologies to all.