Issues installing proprietary BlueMail on Silverblue

I installed BlueMail. It doesn’t work and I want to get rid of it. Running rpm-ostree uninstall BlueMail has no effect. How can I manually delete these files? When I drag them to the trash, I’m told I dont have sufficient permission. I’ve been trying rmdir and rm -r but its not working for me.

1 Like

How did you install?
What taste of Fedora do you play with? (we have 40 tastes) Workstation?


Based on the screenshot you can spotsysroot/ostree
So it is Silverblue, probably.
So dnf doesn’t work here.

1 Like

I am using Silverblue, version 35. I downloaded the rpm file directly from BlueMail’s site. I clicked on it and it installed using Software Center. But it doesn’t run properly. I dont know how to get rid of it.

@apollo18 I imagine you used sudo rpm-ostree uninstall BlueMail
Then have you rebooted the machine?

Yes, I should have specified in my original post that its Silverblue.

Yes. I get this:

error: Package/capability ‘BlueMail’ is not currently requested

Yes. Because it is not currently installed.

rpm -qa |grep -i bluemail
should not output anything.

What you see about bluemail is probably the previous deployment (the one containing the layered RPM).

What is the output of
rpm-ostree status

I see this:

State: idle
● fedora:fedora/35/x86_64/silverblue
                   Version: 35.20211129.0 (2021-11-29T00:41:46Z)
                    Commit: 2f5a3582366ecfc341241a54881abf66699d10523b04849f2a47ac369c99828b
              GPGSignature: Valid signature by 787EA6AE1147EEE56C40B30CDB4639719867C58F

                   Version: 35.20211129.0 (2021-11-29T00:41:46Z)
                BaseCommit: 2f5a3582366ecfc341241a54881abf66699d10523b04849f2a47ac369c99828b
              GPGSignature: Valid signature by 787EA6AE1147EEE56C40B30CDB4639719867C58F
           LayeredPackages: gnome-tweak-tool neofetch
             LocalPackages: BlueMail-1.1.119-1588.x86_64
1 Like

As you can see, BlueMail is not part of the current deployment (the one with the circle).

Yes. So how can I manually delete all those files it deposited on my laptop? Is there a way to use Terminal to delete any file containing the string “bluemail”?

You can wait the next rpm-ostree update so it will be removed automatically.

However, if rpm -qa |grep -i bluemail doesn’t return anything, it means that such software is not currently installed on your (current running) system.

Of course, you can delete such deployment (the entire deployment, not the single files or directories: it is how Fedora Silverblue works, immutable system you know) if you are sure that you don’t need to roolback to it.

Did you search for those files before or after running rpm-ostree uninstall? If you would like to reset back to no layered anything use rpm-ostree reset. If those files are there after reboot from the uninstall, I would then try the reset command. It won’t touch your home directory though and maybe the uninstall command won’t either since it may not know what Blue Mail would install there or even how to find it. Anything in the search that is shown as being under sysroot is likely not to be user touched directly.

I tried rpm-ostree reset but it didn’t get rid of those BlueMail files. What I ended up doing was going into each individual directory and using rm -rf to delete everything that was in the screenshot I posted above. I was trying rm -r but discovered I needed rf to force the delete. Tedious, but it worked. I wont be trying to make unsupported software work again.

Just for you to note, @apollo18 The little dot next to fedora ● fedora:fedora/35/x86_64/silverblue means you were in that tree, but the software you installed, was layered onto the tree below. I suspect that is why it did not immediately work for you.

Not sure what that means. Can you suggest some documentation to read about trees and layering?

This is all so interesting to me!

Start here Fedora Silverblue User Guide :: Fedora Docs


Have at it! Also, I hope you give it another try, there’s a lot to learn.

1 Like

Try alse ostree admin status
With this command you will see, again, the current deployment (the one with the asterisk) and the previous one.
You will probably find the 3f488... string that is to the path under /sysroot/ostree/deploy, corresponding to the previous deployment (the one with the BlueMail RPM installed). Deployment you can rollback to just in case.
Or that you can delete with sudo ostree admin undeploy 1 (0 is the current one, 1 is the previous one).
As said by @jakfrost, sysroot should not be user touched directly.
Of course, as usual, there are directories not “included” in the OS deployment (i.e. the home, temporary directories, logs, caches).