Dnf DRPM not needed

The DRPM feature of dnf --update is a vestige of the days of dial-up modems. It is unnecessary with a fiber-optic or 100Mb DSL internet connection. The DPRM now just delays the file downloads. Is there a switch to turn off DPRM processing?

sudo dnf config-manager --save --setopt deltarpm=False

F40 Change Proposal: Drop Delta RPMs (System Wide)

2 Likes

RTFM Redhat bugzilla suggests add deltarpm=False in dnf.conf

Thank you, Master Valentini for your v40 proposal!

I’ll just go away, now.

1 Like

I can categorically state that placing deltarpm=False within the /etc/dnf/dnf.conf file does not stop the system from downloading drpm files. I have had that setting for the last year and it still gets the drpm instead of the full rpm file.

It is unnecessary for “flat rate” internet access. But for the people that pay per traffic this thing can mean a lot:

:scissors:

[DRPM 22/23] libreoffice-calc-7.5.7.1-1.fc38_7.5.8.2-1.fc38.x86_64.drpm: done  
[DRPM 23/23] firefox-langpacks-119.0-5.fc38_119.0.1-1.fc38.x86_64.drpm: done   
--------------------------------------------------------------------------------
Total                                           9.3 MB/s | 296 MB     00:31     
Delta RPMs reduced 362.4 MB of updates to 296.1 MB (18.3% saved)

With fiber optic 1G connection and modern computer You shouldn’t be bothered whether delta rpm is enabled or disabled. :smile:

There’s one more option that might help. [1] Have You tried deltarpm_percentage=0?


  1. I don’t know, I’ve just set it, did the update, and drpms didn’t show up. We’ll see in few more days. ↩︎

That is exactly the same thing.

I update 9 fedora systems weekly and it is rare to see that size of savings.
More typical is 1% to 3%. I worked this out from months worth of logs of dnf updates.

That’s true. Anything more than 5% is rare in my experience also.

I agree 100%.
The only time it has no chance of saving data is when a drpm is corrupted during the download (which can happen) then it must also download the full rpm to replace it which may actually increase the total downloaded. If only downloading the rpm a corrupted download seems to resume at the point where it failed so there is seldom extra downloaded data.

s/corrupted/interrupted/

It’s probably because it only has to transfer the file from repo. Both wget and curl can do that “continue” thing.

Deltas seem to be more complicated because of calculating and producing the difference to download and than patching with this difference. It takes some time.

Nonetheless, I updated two more machines with deltarpm_percentage=0 added to dnf.conf and there were no drpm in sight. There’s a chance I’ll be missing them, we had such a good time …

I will try adding that option as well. Thanks.

This newbie to Redhatland failed to grasp the fact that delta rpms are additions to an existing rpm package. Certainly it is faster to download a delta than the entire new package. The difference wanes in the presence of a 500Mbps or 940Mbps fiber connection, but as long as there are folks with much slower internet connection speeds any feature to reduce download time is welcome.

But deltarpms do not offer enough reduction compared to the expense of supporting the code and infrastructure to create them.