Display manager doesn't start on boot


When booting on my laptop, my display manager will not start unless I systemctl start it manually. Instead, at boot-up, I get kicked to the command line… with no errors. I have tried gdm, lightdm, lxdm, and a couple TUI display managers - none of them work on startup.

I also tried removing both the display-manager.service and gdm.service, rebooting, and re-adding them. This doesn’t seem to change anything. Running sudo systemctl status gdm reports that the service is “inactive and dead,” which sounds pretty scary to me.

Here’s a hw-probe that should include relevant logs for smarter users: HW probe of Lenovo ThinkPad P14s Gen 1 ... #c869642fe9

Many thanks!

Try this:
sudo systemctl set-default graphical.target
or create symbolic link
sudo ln -sf /usr/lib/systemd/system/graphical.target /etc/systemd/system/default.target
check for default login with GUI
systemctl get-default

sudo systemctl enable gdm --now
sudo shutdown -r now


This worked amazingly! Many thanks! :slight_smile:

1 Like

Oke siap. You’re Welcome

A post was split to a new topic: LightDM (Cinnamon) fails to start, sometimes

Thank you! I had the same problem with gdm not starting on a mininal install. Your solution worked perfectly!