Issue about booting with the graphic mode

Hello everyone,
I have trouble booting my fedora computer with the graphic mode.
When the computer starts, it loads the logo of Fedora and the loading circle but after this, it is the black screen of the system console and I have to identify with my username and password and to type “startx”. But what I want is the graphic interface by default, without typing “startx”.
I tried “systemctl set-default” and “systemctl get-default” and the result is “”.
Do you have any solution to fix this problem ?
I use Fedora 33.
Thank you in advance.

One possibility is that the arguments used when booting the kernel include an overriding run-level of 3, i.e. multi-user text mode. If you’ve ever had to boot a kernel into that mode for recovery due to gui issues, the ‘3’ that you’d append to the arguments at boot time may have been preserved.

First install grubby if you don’t have it:

$ sudo dnf install grubby

Then find the default kernel path:

$ sudo grubby --default-kernel        

then, assuming the response shows a default kernel of /boot/vmlinuz-5.8.16-300.fc33.x86_64 :

$ sudo grubby --info /boot/vmlinuz-5.8.16-300.fc33.x86_64

if there is a ‘3’ at the end of the args= line, then that ‘3’ needs to be removed

$ sudo grubby --remove-args="3" --update-kernel /boot/vmlinuz-5.8.16-300.fc33.x86_64

Then do a reboot and see if it worked.

1 Like

I have followed all the steps but unfortunately it doesn’t works, when I restart the computer, it is as always.
But I found that when I start “startx”, I have this “xauth: file /home/myusername/ .serverauth.1087 does not exist”, to you think that this is linked to my problem, and if it is, what shall I do.
Thank you in advance.

Have you checked the status of the GDM service? If not, try

systemctl status gdm

and see if you can get a clue from that. Does it show some error messages from the logs, perhaps?