Disable GRUB Rollback/Options On Startup

Hello, all!

I’m loving Silverblue more and more as time goes on. I’ve been using it as my daily driver pretty consistently. There’s something I am curious about how to disable though!

I’ve set the system to shutdown when the lid is closed by editing /etc/systemd/logind.conf, and it works! However, when I open the laptop back up, I’m booted into the rollback menu, like what you’d see if the system lost power suddenly or shutdown unexpectedly.

This also seems to happen if I use systemctl poweroff, which is super weird to me. systemctl reboot works fine, and shutting down via GNOME’s power menu works as expected.

Not a huge deal though, I’d like to just disable that rollback/recovery menu from popping up when the system experiences this trigger. I can always call it manually by pressing Esc when first booting the system anyway.

I can’t seem to find the appropriate line in GRUB that does this though. If anyone has some insight on what would allow me to disable that rollback screen from showing up, it’d be greatly appreciated!

(In case anyone is inclined to ask about why I want this, I want my laptop to power off on lid close so I don’t have to worry about it being unencrypted in suspend if I forget about it. I just want it off, not using battery, and to be encrypted when not in use. That’s all! :smiley: )

Is it getting all the way to clean shutdown? My first guess is it’s getting cut off before somehow…

1 Like

It seems to be. The result is the same if I run systemctl poweroff, and it seems to shutdown cleanly from what I can see in journalctl.

Even running Fedora 35 (Workstation, not Silverblue) in a VM, if I type systemctl poweroff, I get the recovery menu. But it shuts down normally. It seems this is just a weird thing with systemctl poweroff.

1 Like

Hello @schykle,
I know that the Grub menu on Silverblue will be visible after an unsuccessful shutdown/boot sequence. So for instance, I have experienced times where an update has occurred, nothing came back with an error, reboot was initiated and new commit didn’t boot. Had to reset (hard) then reboot comes up with menu, and new boot is selectable and works from then on. I have a desktop with a newer motherboard which has wireless, so power-profiles-daemon was interfering with my profile, wouldn’t allow performance! So I uninstalled it with an override and installed tuned, which works better for my AMD CPU, and viola no more weird failed boots after update. I’m runniing Rawhide BTW.

1 Like

That’s a super interesting bug! I’m also running an AND CPU myself. Though I generally don’t want to remove any of the power profiles stuff as I use this on the go and so far battery has been pretty stellar.

Honestly the goal is quite literally just turning the recovery/rollback menu off. Like whether the machine crashes or I shutdown with poweroff, I just want it to boot normally. I can always hit Esc on startup to access that menu anyway

Alright, update for everyone who’s interested!

I managed to solve this by making a change in the /etc/default/grub file, and then regenerating the GRUB.

This particular line:


This did nothing in its default state, but by putting quotes around true, it seems to have made a difference!

The new line:


This now seems to allow me to use systemctl poweroff without booting into the advanced/rollback menu, and works correctly with the loginctl’s poweroff option when closing the lid!

Ideally this should not be something that ever happens while using systemctl poweroff, as this should be a fully supported function. BUT, after like a week of digging and banging my head against the wall, I at least now have some kind of solution!

Thanks to @mattdm and @jakfrost for participating in the thread! I learned a lot!