Power button behaviour - Fedora Silverblue 35

Hi all,

I’ve recently clean installed Fedora Silverblue 35 on my laptop.

Unfortunately, whenever I press my laptop’s power button, it immediately shuts off the computer rather than suspends like it did on previous Fedora versions. Due to where it is on the keyboard, I find myself frequently shutting down the computer by accident.

I’ve tried modifying the power-button-action gsetting (located at org.gnome.settings-daemon.plugins.power) but this does not seem to have any effect.

I came up with a quick and dirty workaround by setting InhibitorsMax=0 inside /etc/systemd/logind.conf however this now stops GNOME Shell from shutting down via the menu, so it isn’t really a solution.

Any help would be greatly appreciated :slight_smile:

1 Like

Hello, welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Can you check
hostnamectl chassis
and verify it’s not set to vm

if it is can you set it to laptop?

1 Like

Perfect, thanks! That solved it.

It was set to ‘vm’ for some reason. Setting it to ‘laptop’ makes it work as expected.