Disable built in GPU

Hi all,

I have a new Lenovo with an NVIDIA Geforce RTX 4050 and have installed Fedora 39.

I am trying to disable the built in GPU but I am failing at it.

Currently, I have:

lspci -n -n -k | grep -A 2 -e VGA -e 3D

pcilib: Error reading /sys/bus/pci/devices/0000:00:08.3/label: Operation not permitted
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation AD107M [GeForce RTX 4050 Max-Q / Mobile] [10de:28a1] (rev a1)
	Subsystem: Lenovo Device [17aa:3af8]
	Kernel driver in use: nvidia
--
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt [Radeon 680M] [1002:1681] (rev 0b)
	Subsystem: Lenovo Device [17aa:3af8]
	Kernel driver in use: amdgpu

and

glxinfo | grep -e OpenGL.vendor -e OpenGL.renderer
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon Graphics (radeonsi, rembrandt, LLVM 17.0.6, DRM 3.57, 6.7.10-200.fc39.x86_64)

What do I have to do to disable the AMD Radeon Graphics and make the system use the NVIDIA one?

Thank you

To use that nvidia gpu all that is normally required is to install the driver from the rpmfusion repo.
Please run dnf repolist and see if the repo rpmfusion-nonfree-nvidia-driver is in the list returned.
If it is then the driver may be installed by running the following.

  1. sudo dnf install akmods
  2. reboot
  3. sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
  4. Wait at least 5 minutes then reboot.

Now the nvidia drivers should load and the gpu should be functional.
To confirm the driver is loaded run lsmod | grep nvidia which should return 4 or 5 lines with the nvidia drivers displayed.

Loading the nvidia driver does require that secure boot be disabled or that the user follow the steps shown in the file /usr/share/doc/akmods/README.secureboot to enable loading the driver with secure boot enabled.

1 Like

Thank you!
that worked

2 Likes

Please mark t he appropriate post as the solution for you.
Thanks.