Nvidia GPU unable to use

I am having a hard time trying to put to good use the Nvidia gpu on my laptop.

I have installed the Nvidia driver using the tutorial here:

I ran several benchmarks and they all use my CPU integrated graphics. Also, I didn’t find any option to benchmark my GPU instead.

Additional info:

alex@fedora:~$ nvidia-smi
Fri Apr 26 20:24:19 2024       
+-----------------------------------------------------------------------------------------+
| NVIDIA-SMI 550.76                 Driver Version: 550.76         CUDA Version: 12.4     |
|-----------------------------------------+------------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|=========================================+========================+======================|
|   0  NVIDIA GeForce RTX 3060 ...    Off |   00000000:01:00.0 Off |                  N/A |
| N/A   36C    P0            752W /   80W |       9MiB /   6144MiB |      0%      Default |
|                                         |                        |                  N/A |
+-----------------------------------------+------------------------+----------------------+
                                                                                        
+-----------------------------------------------------------------------------------------+
| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|=========================================================================================|
|    0   N/A  N/A      3601      G   /usr/libexec/Xorg                               4MiB |
+-----------------------------------------------------------------------------------------+
WARNING: infoROM is corrupted at gpu 0000:01:00.0
alex@fedora:~$ cat /etc/modprobe.d/blacklist.conf 
blacklist nouveau
alex@fedora:~$ lspci -v | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1) (prog-if 00 [VGA controller])
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne [Radeon Vega Series / Radeon Vega Mobile Series] (rev c6) (prog-if 00 [VGA controller])
alex@fedora:~$ dnf list installed | grep nvidia
akmod-nvidia.x86_64                                  3:550.76-1.fc39                     @rpmfusion-nonfree-updates
kmod-nvidia-6.8.5-201.fc39.x86_64.x86_64             3:550.67-1.fc39                     @@commandline             
kmod-nvidia-6.8.6-200.fc39.x86_64.x86_64             3:550.67-1.fc39                     @@commandline             
kmod-nvidia-6.8.7-200.fc39.x86_64.x86_64             3:550.76-1.fc39                     @@commandline             
nvidia-gpu-firmware.noarch                           20240410-1.fc39                     @updates                  
nvidia-modprobe.x86_64                               3:550.76-1.fc39                     @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                           3:550.76-1.fc39                     @rpmfusion-nonfree-updates
nvidia-settings.x86_64                               3:550.76-1.fc39                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                           3:550.76-1.fc39                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                      3:550.76-1.fc39                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                 3:550.76-1.fc39                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                   3:550.76-1.fc39                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                      3:550.76-1.fc39                     @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                     3:550.76-1.fc39                     @rpmfusion-nonfree-updates


INTTF occasionally has some problems with fedora since fedora updates kernels so rapidly.

We always recommend that users install nvidia drivers from the rpmfusion repo as first choice since those packages are specifically tweaked and tested to work with fedora.

Personally I would remove everything you may have installed from the INTTF tutorial/guide then reinstall from rpmfusion as shown there.

I note that your listing of installed packages shows they were installed from rpmfusion.
With the error message shown in the nvidia-smi output I would first rebuild the driver modules to see if the module itself may be corrupted.

  1. sudo dnf remove kmod-nvidia-6.8.7-200.fc39.x86_64
    then rebuild those modules with
  2. sudo akmods --force
1 Like

I have some more HARSH things to say about INTTF & the Propiretary Nvidia Driver, but I digress.

I followed your instructions (including the driver removal and installation from rpmfusion) and I am getting the same output for nvidia-smi as before.

LE: Also checked this… and it doesn’t seem right

alex@fedora:~/benchmarks/Unigine_Heaven-4.0$ inxi -G | grep nvidia
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
    loaded: amdgpu,nvidia unloaded: fbdev,modesetting,vesa dri: radeonsi
  API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast

We need to see the full output of inxi -Fzxx as well as dnf list installed \*nvidia\*

alex@fedora:~$ inxi -Fzxx
System:
  Kernel: 6.8.7-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-14.fc39
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 wm: kwin_x11 dm: SDDM
    Distro: Fedora Linux 39 (KDE Plasma)
Machine:
  Type: Laptop System: LENOVO product: 82JU v: Legion 5 15ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 15ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    part-nu: LENOVO_MT_82JU_BU_idea_FM_Legion 5 15ACH6H UEFI: LENOVO v: GKCN58WW
    date: 09/15/2022
Battery:
  ID-1: BAT0 charge: 74.7 Wh (100.0%) condition: 74.7/80.0 Wh (93.3%)
    volts: 17.2 min: 15.4 model: Celxpert L20C4PC1 serial: <filter> status: full
CPU:
  Info: 6-core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 684 high: 1815 min/max: 400/4280 cores: 1: 400 2: 1397
    3: 1398 4: 400 5: 400 6: 400 7: 1815 8: 400 9: 400 10: 400 11: 400 12: 400
    bogomips: 79059
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 550.76 arch: Ampere pcie: speed: 8 GT/s lanes: 8 ports:
    active: none empty: DP-1, DP-2, HDMI-A-1, eDP-2 bus-ID: 01:00.0
    chip-ID: 10de:2560
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 pcie: speed: 8 GT/s
    lanes: 16 ports: active: eDP-1 empty: none bus-ID: 06:00.0
    chip-ID: 1002:1638 temp: 35.0 C
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-3:3 chip-ID: 04f2:b725
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: fbdev,modesetting,vesa alternate: nouveau,nv dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x5895 res: 1920x1080
    dpi: 142 diag: 394mm (15.5")
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: radeonsi
    device: 3 drv: swrast surfaceless: drv: nvidia x11: drv: radeonsi
    inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.6 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi renoir LLVM
    17.0.6 DRM 3.57 6.8.7-200.fc39.x86_64) device-ID: 1002:1638
  API: Vulkan v: 1.3.275 surfaces: xcb,xlib device: 0 type: integrated-gpu
    driver: N/A device-ID: 1002:1638 device: 1 type: discrete-gpu driver: N/A
    device-ID: 10de:2560 device: 2 type: cpu driver: N/A device-ID: 10005:0000
Audio:
  Device-1: NVIDIA GA106 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: speed: 8 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:228e
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    pcie: speed: 8 GT/s lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 06:00.6 chip-ID: 1022:15e3
  API: ALSA v: k6.8.7-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
    v: kernel pcie: speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2725
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-4:2 chip-ID: 8087:0032
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
Drives:
  Local Storage: total: 1.38 TiB used: 66.94 GiB (4.8%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS512GDE9X084N
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 33.9 C
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 26.9 C
Partition:
  ID-1: / size: 476.94 GiB used: 66.89 GiB (14.0%) fs: btrfs
    dev: /dev/nvme0n1p1
  ID-2: /boot/efi size: 1022 MiB used: 44.9 MiB (4.4%) fs: vfat
    dev: /dev/nvme1n1p1
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 59.2 C mobo: N/A gpu: amdgpu temp: 35.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 13.5 GiB used: 3.78 GiB (28.0%)
  Processes: 390 Power: uptime: 4m wakeups: 0 Init: systemd v: 254
    target: graphical (5) default: graphical
  Packages: 38 pm: flatpak pkgs: 29 pm: snap pkgs: 9 Compilers: gcc: 13.2.1
    Shell: Bash v: 5.2.26 running-in: terminator inxi: 3.3.34
alex@fedora:~$ dnf list installed \*nvidia\*
Installed Packages
akmod-nvidia.x86_64                                                                                                   3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
kmod-nvidia-6.8.7-200.fc39.x86_64.x86_64                                                                              3:550.76-1.fc39                                                                              @@commandline             
nvidia-gpu-firmware.noarch                                                                                            20240410-1.fc39                                                                              @updates                  
nvidia-modprobe.x86_64                                                                                                3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                                                                                            3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                                                                3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                                                            3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                                                                       3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                                                  3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                                                    3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                                                       3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                                                                                      3:550.76-1.fc39                                                                              @rpmfusion-nonfree-updates

@computersavvy hey, would you mind providing your input when you have a moment?

thanks

Mine looks basically like yours except I have intel + nvidia and you have nvidia + amd for GPUs.
I would hope that you have already updated since posting that data. The kernel is now 6.8.10 and the nvidia driver is now 550.78

sudo dnf upgrade --refresh followed by waiting at least 5 minutes before rebooting.

I believe there were some instances with the 6.8.7 - 6.8.9 kernels where problems of this sort appeared and that the 6.8.10 kernel seems to have fixed most of them.
It has been long enough since f40 was released that I also would suggest that you consider updating to f40 as most of the early bugs have been stomped out.

I always keep my stuff up to date, including the kernel. Even thought I ran the upgrade command, I didn’t get updates for the gpu.

There’s a thing that I noticed recently… when I upgrade the kernel or do some update that required reboot, I’m getting the message “nvidia kernel module missing falling back to nouveau” on the loading update screen. This made me question if there are any residual files that remained after I wiped the drivers installed from the nvidia website.

Either way, I still have hope to find a fix for my problem on f39(haven’t studied the stuff on f40, so I prefer to not upgrade).

I think we are missing something… maybe there is a clue in the photos attached in my initial post. Also, I don’t see the nvidia gpu showing in the system settings >> about this system.

The nvidia gpu shows in the image of neofetch.

Lets do a little more digging.
Please post the outputs of inxi -Fzxx and dnf list installed \*nvidia\* again. Then add sudo dmesg | grep -iE "nouveau|nvidia|secure"

We can work from that point forward.

alex in ~ λ inxi -Fzxx
System:
  Kernel: 6.8.10-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-14.fc39
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.10 wm: kwin_x11 dm: SDDM
    Distro: Fedora Linux 39 (KDE Plasma)
Machine:
  Type: Laptop System: LENOVO product: 82JU v: Legion 5 15ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 15ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    part-nu: LENOVO_MT_82JU_BU_idea_FM_Legion 5 15ACH6H UEFI: LENOVO v: GKCN58WW
    date: 09/15/2022
Battery:
  ID-1: BAT0 charge: 70.0 Wh (97.0%) condition: 72.2/80.0 Wh (90.2%)
    volts: 17.2 min: 15.4 model: Celxpert L20C4PC1 serial: <filter>
    status: not charging
CPU:
  Info: 6-core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1639 high: 2412 min/max: 400/4280 cores: 1: 1916 2: 2394
    3: 2395 4: 2412 5: 2123 6: 400 7: 2395 8: 2394 9: 400 10: 400 11: 400
    12: 2043 bogomips: 79045
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 550.78 arch: Ampere pcie: speed: 5 GT/s lanes: 8 ports:
    active: none off: HDMI-A-1 empty: DP-1,DP-2,eDP-2 bus-ID: 01:00.0
    chip-ID: 10de:2560
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 pcie: speed: 8 GT/s
    lanes: 16 ports: active: eDP-1 empty: none bus-ID: 06:00.0
    chip-ID: 1002:1638 temp: 43.0 C
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: fbdev,modesetting,vesa alternate: nouveau,nv dri: radeonsi
    gpu: amdgpu,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: primary,right
    model: MSI MP243 res: 1920x1080 dpi: 93 diag: 604mm (23.8")
  Monitor-2: eDP-1 mapped: eDP pos: left model: AU Optronics 0x5895
    res: 1920x1080 dpi: 142 diag: 394mm (15.5")
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: radeonsi
    device: 3 drv: swrast surfaceless: drv: nvidia x11: drv: radeonsi
    inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.6 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi renoir LLVM
    17.0.6 DRM 3.57 6.8.10-200.fc39.x86_64) device-ID: 1002:1638
  API: Vulkan v: 1.3.275 surfaces: xcb,xlib device: 0 type: integrated-gpu
    driver: N/A device-ID: 1002:1638 device: 1 type: discrete-gpu driver: N/A
    device-ID: 10de:2560 device: 2 type: cpu driver: N/A device-ID: 10005:0000
Audio:
  Device-1: NVIDIA GA106 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: speed: 8 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:228e
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    pcie: speed: 8 GT/s lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 06:00.6 chip-ID: 1022:15e3
  API: ALSA v: k6.8.10-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
    v: kernel pcie: speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2725
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-4:2 chip-ID: 8087:0032
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
Drives:
  Local Storage: total: 1.38 TiB used: 605.55 GiB (43.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 38.9 C
  ID-2: /dev/nvme1n1 vendor: SK Hynix model: HFS512GDE9X084N
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 45.9 C
Partition:
  ID-1: / size: 476.94 GiB used: 90.42 GiB (19.0%) fs: btrfs
    dev: /dev/nvme1n1p1
  ID-2: /boot/efi size: 1022 MiB used: 44.9 MiB (4.4%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 256 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 52.6 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 13.49 GiB used: 4.44 GiB (32.9%)
  Processes: 385 Power: uptime: 31m wakeups: 0 Init: systemd v: 254
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 29 Compilers: clang: 17.0.6 gcc: 13.3.1
    Shell: Bash v: 5.2.26 running-in: terminator inxi: 3.3.34

alex in ~ λ dnf list installed \*nvidia\*
Installed Packages
akmod-nvidia.x86_64                                                                                                   3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
kmod-nvidia-6.8.10-200.fc39.x86_64.x86_64                                                                             3:550.78-1.fc39                                                                              @@commandline             
kmod-nvidia-6.8.8-200.fc39.x86_64.x86_64                                                                              3:550.78-1.fc39                                                                              @@commandline             
kmod-nvidia-6.8.9-200.fc39.x86_64.x86_64                                                                              3:550.78-1.fc39                                                                              @@commandline             
nvidia-gpu-firmware.noarch                                                                                            20240513-1.fc39                                                                              @updates                  
nvidia-modprobe.x86_64                                                                                                3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                                                                                            3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                                                                3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                                                            3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                                                                       3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                                                  3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                                                    3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                                                       3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                                                                                      3:550.78-1.fc39                                                                              @rpmfusion-nonfree-updates
alex in ~ λ sudo dmesg | grep -iE "nouveau|nvidia|secure"
[sudo] password for alex: 
[    0.000000] Command line: BOOT_IMAGE=(hd1,gpt1)/boot/vmlinuz-6.8.10-200.fc39.x86_64 root=UUID=3ea6328a-505d-479a-bdc1-d2eda13603f9 ro rd.driver.blacklist=nouveau modprobe.blacklist=nouveau rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[    0.000000] secureboot: Secure boot disabled
[    0.005472] secureboot: Secure boot disabled
[    0.031258] Kernel command line: BOOT_IMAGE=(hd1,gpt1)/boot/vmlinuz-6.8.10-200.fc39.x86_64 root=UUID=3ea6328a-505d-479a-bdc1-d2eda13603f9 ro rd.driver.blacklist=nouveau modprobe.blacklist=nouveau rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[    4.969899] amdgpu 0000:06:00.0: amdgpu: SECUREDISPLAY: securedisplay ta ucode is not available
[    7.704793] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input24
[    7.705040] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input25
[    7.705186] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input26
[    7.705266] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input27
[    8.473427] nvidia: loading out-of-tree module taints kernel.
[    8.473438] nvidia: module license 'NVIDIA' taints kernel.
[    8.473465] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    8.473467] nvidia: module license taints kernel.
[    8.948773] nvidia-nvlink: Nvlink Core is being initialized, major device number 509
[    8.950174] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    8.950272] nvidia 0000:01:00.0: vgaarb: VGA decodes changed: olddecodes=io+mem,decodes=none:owns=none
[    8.998768] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  550.78  Sun Apr 14 06:35:45 UTC 2024
[    9.061102] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[    9.168156] nvidia-uvm: Loaded the UVM driver, major device number 507.
[    9.222626] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  550.78  Sun Apr 14 06:23:31 UTC 2024
[    9.228103] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   10.872319] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device DP-4
[   10.881751] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device DP-4
[   11.027162] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[   11.128106] nvidia 0000:01:00.0: [drm] fb1: nvidia-drmdrmfb frame buffer device
[   16.866296] [drm] [nvidia-drm] [GPU ID 0x00000100] Framebuffer memory not appropriate for scanout
[   16.869585] [drm] [nvidia-drm] [GPU ID 0x00000100] Framebuffer memory not appropriate for scanout

Those show the nvidia driver is loaded and in use.

Exactly what is the problem you see that implies it is not working?

I see this but need more info to know the cause and be sure it is what you see as the problem.

Is the monitor (internal or external) not working?
How is it connected?
What are the symptoms?

I don’t know if you use Blender or those types of Applications, but if you need to explicitly use the Nvidia GPU you can do so by choosing it when the applications starts :

Here is Blender :
Screenshot from 2024-05-20 11-02-54

Then using Krita :
Screenshot from 2024-05-28 11-36-12

I would have to choose to use Nvidia while using Krita, Blender is using it by default after some tweaks.

Here is using Steam :
Screenshot from 2024-05-28 11-38-07

What do you see when you launch an application using the Discrete GPU (Nvidia) using nvidia-smi :thinking: Here is my nvidia-smi :

nvidia-smi 
Tue May 28 11:40:47 2024       
+-----------------------------------------------------------------------------------------+
| NVIDIA-SMI 550.78                 Driver Version: 550.78         CUDA Version: 12.4     |
|-----------------------------------------+------------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|=========================================+========================+======================|
|   0  NVIDIA GeForce RTX 3050 ...    Off |   00000000:01:00.0 Off |                  N/A |
| N/A   53C    P8              3W /   60W |     203MiB /   4096MiB |      0%      Default |
|                                         |                        |                  N/A |
+-----------------------------------------+------------------------+----------------------+
                                                                                         
+-----------------------------------------------------------------------------------------+
| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|=========================================================================================|
|    0   N/A  N/A     20305      G   /usr/bin/gnome-shell                            1MiB |
|    0   N/A  N/A    135603    C+G   ./blender                                     155MiB |
|    0   N/A  N/A    135927      G   ...local/share/Steam/ubuntu12_32/steam          2MiB |
|    0   N/A  N/A    137249      G   ./steamwebhelper                               34MiB |
+-----------------------------------------------------------------------------------------+

I am on Fedora Workstation 40 , Wayland default session, I’m not sure what you are using, as I see only Xorg ?

I have an external monitor connected through HDMI and it’s working.

The reason for which I created this thread is that I’ve been unable to set explicitly my nvidia gpu in various programs(because the option for dedicated gpu just doesn’t show), such as: benchmark apps(gxgears thing, unigine), mandelbrot generators, or Unity 3D. I don’t play games or do 3D modelling on linux(yet). So I thought there’s something wrong with my drivers.

Though, I installed a random game and while I run it, I notice some impressing output:

+-----------------------------------------------------------------------------------------+
| NVIDIA-SMI 550.78                 Driver Version: 550.78         CUDA Version: 12.4     |
|-----------------------------------------+------------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|=========================================+========================+======================|
|   0  NVIDIA GeForce RTX 3060 ...    Off |   00000000:01:00.0  On |                  N/A |
| N/A   41C    P0             26W /   95W |     310MiB /   6144MiB |     24%      Default |
|                                         |                        |                  N/A |
+-----------------------------------------+------------------------+----------------------+
                                                                                         
+-----------------------------------------------------------------------------------------+
| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|=========================================================================================|
|    0   N/A  N/A      1818      G   /usr/libexec/Xorg                              77MiB |
|    0   N/A  N/A      6411      G   /usr/bin/supertuxkart                         218MiB |
+-----------------------------------------------------------------------------------------+

I’m using Xorg/X11 since I’ve heard Wayland isn’t too friendly with nvidia gpus.

Can you switch to a Wayland session ? Just to test. I don’t think those options i captured for you appear on Xorg that I know. . .

I also use X11. My reasoning is that there are certain apps that are not 100% wayland friendly and I do not wish to switch back and forth between wayland and X11 since that requires a logout + login to do so.

For the most part, with the specific app exception, nvidia and wayland work very well together and nvidia is always working to make improvements since wayland is now the DE used on most distros.

The apps themselves now have to be modified to work with wayland. Chrome is one that glitches for me as does steam and another that is locally compiled from source.

I suspect some of the glitches are related to qt vs gtk variances.

Since you have been using X11, you can choose to make the nvidia gpu primary so it is always used if you follow the steps here. That option is up to you.

1 Like

I found no improvement after switching to Wayland.

Hmm… @computersavvy, I feel like you want to tell me that it’s not needed to primarily use the dedicated gpu if I don’t really need it. Well, I agree with that but I just want to be sure that if I ever need it, I can go straight ahead and use it.

I tried again to run benchmarks: glxgears, glmark2 — these were using the integrated gpu.
As a final benchmark app try, I used Heaven and Superposition from Unigine. (All of these benchmarks were ran while observing stats on nvtop + btop and the low fps shown on the benchmark screen)
In fact, I didn’t find any setting to explicitly use my dedicated gpu, but this var specified at running Unigine apps: DRI_PRIME=1 — this one gave me an unexpected output in the terminal:

alex in ~/Downloads/Unigine_Superposition-1.1 λ DRI_PRIME=1 ./Superposition
glx: failed to create dri3 screen
failed to load driver: nouveau

If you are certain that the tutorial from the link provided would solve my issue and the hints I gave you are not considered relevant, we can mark this topic as solved.

Did you try these under Wayland ? Forced use of the Nvidia driver?

I see we have the same Nvidia card and almost the same laptop.

The first time I installed the Nvidia driver on Fedora I followed instructions I found on the net, but I can’t find them anymore. No idea where I found it.
Where it comes down to is:
Install the rpmfusion repo’s and reboot
install the driver using:

sudo dnf install akmod-nvidia xorg-x11-drv-nvidia
sudo kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1

After installing the driver you need to wait a minimum of 5 minutes before rebooting to allow the kernel modules to be created. Just wait till you see the CPU usage go down to almost zero for a long period of time.

At the end the webpage showed me a file I had to place in the /etc folder.
The name of the file is environment and the content is:

QT_QPA_PLATFORMTHEME="wayland;xcb"
GBM_BACKEND=nvidia-drm
__GLX_VENDOR_LIBRARY_NAME=nvidia
ENABLE_VKBASALT=1
LIBVA_DRIVER_NAME=nvidia

WLR_NO_HARDWARE_CURSORS=1

After having placed the file you need to reboot again.

It worked and I was constantly using the Nvidia card and driver. So if that is what you’re after then try it. Just reboot after placing the file and it should work.
But you really shouldn’t have to do that cause the Nvidia card will pitch in when needed automatically, at least it does so here in my laptop.

True, but my real intent was to show that since you are using x11 anyway it is simple to have the nvidia gpu become the primary and be used all the time.

The post by @jandemus seem like it may be a way to have the nvidia gpu be used more under wayland and I am interested to test that on my laptop. Will try that later today.