Davinci resolve does not run in fedora 39

i install fedora 39 and then download Davinci resolve from official site and run file but it davinci do not open and i try the following solution

cd /opt/resolve/libs

mkdir disabled && mv libglib* libgio* libgmodule* disabled</>

sudo dnf install libcurl libcurl-devel</>

but it is not work

kindlly help me

You are not alone:

2 Likes

I have same issue my log output is below. Hangs on GPU detect. I got this to launch once. The process now hangs in the back ground and I can’t kill it. Running an AMD 6900XT.

0x7f9ba7a36100 | Undefined | INFO | 2023-12-13 07:03:38,128 | --------------------------------------------------------------------------------
0x7f9ba7a36100 | Undefined | INFO | 2023-12-13 07:03:38,128 | Loaded log config from /home//.local/share/DaVinciResolve/configs/log-conf.xml
0x7f9ba7a36100 | Undefined | INFO | 2023-12-13 07:03:38,128 | --------------------------------------------------------------------------------
0x7f9ba7a36100 | Main | INFO | 2023-12-13 07:03:38,129 | Running DaVinci Resolve Studio v18.6.4.0006 (Linux/Clang x86_64)
0x7f9ba7a36100 | Main | INFO | 2023-12-13 07:03:38,129 | BMD_BUILD_UUID 3b420924-3d77-46fd-b9be-010a0dd7002a
0x7f9ba7a36100 | Main | INFO | 2023-12-13 07:03:38,129 | BMD_GIT_COMMIT ed460445297a0b11ca4156fec0c5b0d405114883
0x7f9ba7a36100 | GPUDetect | INFO | 2023-12-13 07:03:38,130 | Starting GPUDetect 1.2_5-a6

Disabling libgpudetect.so by move to the _disabled folder has apparently worked once for someone, possibly try this out and report back with findings.

Thanks for responding. Didn’t work. Here is what I’ve moved to disabled. Again thanks for your help.

Crazy question, Have you rebooted the machine since this change?

I did. Had to hard boot it. Locked up after I tried to force kill resolve.

I guess we could try moving down to an older kernel as well? Just reboot, and choose an older kernel, If you are up for it. If you recently upgraded you could use a .f38 kernel since you already have the libs in disabled. . . Up to you though.

I’m on a fresh install. I’m retrying out Linux (do this every X years). I’ll wait and see what happens with future updates. Resolve is more of a hobby than work. Thanks for your help.

1 Like

Apparently this is an issue with F39 specifically, so the other option is to Install F38 and hold off for a a bit.

On my main work machines I wait 3 months sometimes to update because of the possible issues. I test in software in containers on new system upgrades until it’s all ironed out then upgrade main machines when ready.

2 Likes

After moving the disabled files, this worked for me

download libgdk fedora’s rpm : https://dl.fedoraproject.org/pub/fedora/linux/releases/38/Everything/x86_64/os/Packages/g/gdk-pixbuf2-2.42.10-2.fc38.x86_64.rpm

Extract it : rpm2cpio ./gdk-pixbuf2-2.42.10-2.fc38.x86_64.rpm | cpio -idmv

enter the extracted usr/lib64 and open a terminal in it : sudo cp -r * /opt/resolve/libs/

4 Likes