Davinci resolve with amd gpu on f38

Soo, i’ve tried and tried, hours and days, to no avail. Here is to hope

I am Fedora 38, full upgraded, Amd cpu, amd vega mobile gpu (lenovo yoga laptop).
I recently got Davinci resolve working on intel/nvidia, and got hopeful. Maybe too hopeful, and installed 18.6 on the yoga.

I have scoured the net, and heard many things about amdpro, rocm, vulkan even freeworlds, most of which i sadly don’t understand. No combination of the many things i tried got resolve to work.
It starts, started right from clean slate. But doesn’t render videos (same video as works on intel/nvidia, DNxHD codec). The most pertinent error i see in resolve logs is that it tries and fails to get an opencl context.

I’m not sure what else info is needed, as i have no idea what is broken/not working. But i have a bunch of mesa installed
mesa-libGL.i686 23.1.8-1.fc38 @updates
mesa-libGL.x86_64 23.1.8-1.fc38 @updates
mesa-libGLU.x86_64 9.0.3-1.fc38 @updates
mesa-libOpenCL.x86_64 23.1.8-1.fc38 @updates
mesa-libgbm.i686 23.1.8-1.fc38 @updates
mesa-libgbm.x86_64 23.1.8-1.fc38 @updates
mesa-libglapi.i686 23.1.8-1.fc38 @updates

also amd-gpu-firmware.noarch 20230919-1.fc38
and xorg-x11-drv-amdgpu.x86_64 23.0.0-1.fc38 @fedora

I had tried rocm* at some point but since it didn’t work, i removed them.
Also tried and failed on all amd pro attempts.
Also no difference with wayland/x11

Help apreciated, though i am a little resigned after this https://www.youtube.com/watch?v=ltGNxWvZZuM

1 Like

not sure does this helps but seen this on multiple platforms now and took this on Nobara website that has made all build in

"It’s been reported that some users may need to install the following additional packages for DR to run: mesa-libOpenCL, apr, and apr-util.

Please note that DaVinci Resolve does not have the ability to encode video on AMD GPU hardware. The H264 and H265 encode options are only available on Nvidia hardware and only in the Studio version."

Thanks for trying @phatle , but apr and apr-util were installed. So no go.

And i have resigned myself to transcoding, as probaly all linux dr users. I would pay for the studio, but even that does not do aac, so ffmpeg it is. Until someone writes a plugin or BlackMagic sees the light.

So, still open

Eureka. I followed one more lead about the opencl version. I read somewhere that DR needs 1.2, but the mesa-libOpenCL only has 1.1
Looking for workarounds i revisited rocm and installed. But this time also removed the mesa

sudo dnf install rocm-opencl
sudo dnf remove mesa-libGL

And it works. It scrubs HD without noticeable lag (DNxHD/pcm as mentioned above)
Thanks to the little gods of bits and all their helpers in the linux realm.