Fedora 39 does not run Davinci Resolve 18.6

Hey guys!
I just installed Fedora 39 on a Lenovo notebook with 8GB of RAM and an NVIDIA graphics card. I then installed Davinci Resolve 18.6.6 following Blackmagic’s recommendations.
However, Fedora does not run Resolve, the editing software, specifically. Other software, such as Blackmagic RAW Player, which comes with the installation, runs.
I have already tried the solution mentioned in this thread, but without success.

I record a video to show the problem:

Any suggestion?

1 Like

If you have not tried run it from a terminal where the errors are easier to see.
What errors do you get?

When I run the “resolve” executable via terminal, which is in “/opt/resolve/bin/”, nothing happens. See the image:

Does that say “command not found”? That will mean that /opt/resolve/bin is not on your PATH?

What happens if you type /opt/resolve/bin/resolve? Does the program run then?

When I type /opt/resolve/bin/resolve this image appears above.

In the image below, there is the root of my installation:

I don’t see the executable in that image there? Should it be in bin directory there? That path is /opt/resolve

You can try this here :

cd /opt/resolve/bin/
chmod +x resolve

If Resolve is not in your PATH, you can

export PATH=$PATH:/opt/resolve/bin/

Yes, the “resolve” executable is in the /bin folder.
When I go to the terminal and type “resolve” to run it, nothing happens.
What can I do?

Ypu must add the path to the bin folder to your PATH.
You can do this in your ~/.bash_profile after any other lines that change the PATH.


Log out and back in and try again.

Put a ./ in front of resolve and hit enter
/opt/resolve/bin$ ./resolve
Logs are located here

Did you install the Nvidia drivers?

The ~/.bash_profile file I found looks like this.

Add the line I suggested at line 2.

when I run ./resolve this happened

error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

I don’t know if I installed the Nvidia drivers. Does Fedora not install automatically?

Yup, running in a terminal helped me ‘resolve’ my issue running with the software.
I’m using an AMD card. I web searched and found instructions below. There could also be instructions on this forum.

I made the changes, but it didn’t work.

Maybe this. Don’t run Nvidia won’t be much help.

Yes, the NVIDIA driver is installed.

And when I run ./resolve in the /opt/resolve/bin/ folder I get this message:

./resolve: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

Try installing this libxcrypt-compat

I followed the article above to install NVIDIA and look what happened! The note only turns on like this now:

That method of manually installing the drivers is not recommended. The Nvidia driver repo is already part of the third party repos. That article is from 2017. . .

1 Like

It pains me to see this. . . Do you have a USB with Fedora image on it? You will need to do some work to get this back to normal.

1 Like