Cut Paste shortcuts issue


I hope to get some help here, I really don’t know how to tackle this issue I’m experience in the last days.

Since a few days, ctrl+c and ctrl+x work randomly in every application.
For example, if I want to copy some string in gedit, I need to press ctrl+c many times to actually copy it in the clipboard.
The “cut” shortcut has basicaly become useless instead. In fact, it always correctly deletes the text, but it doesn’t copy that to the clipboard. The result is that the text disappear, but I can’t paste it.

As far as I know, I haven’t done anything special in the last days that might have caused this issue.

I use Fedora 31, gnome-shell 3.34.1.

Can you please give me some help, at least, on how to start debugging this issue? It’s a real pain.

1 Like

This may be due to the different behavior for the GTK/Qt apps running Wayland/XWayland.
You can try to temporarily work around the problem using the X11 session type and wait for updates.

Crtl+z (undo) doesn’t work too ?

No, it’s just the action of pasting the last copied text/image.

I can check that the Copy action works thanks to a clipboard gnome extension that adds an icon indicator on the top-panel that opens a popover menu filled with a list of notes in the clipboard.
I can see that the text I copy always appears as an item in that list.

By the way, I tried disabling all extensions and MAYBE it worked back again. It’s hard to say because this issue happens randomly, and I need to be in the middle of some heavy work, in which I do a lot of copy/cut/paste in order to be enough confident that the issue is due to some gnome extension.

IF the issue is a gnome extension, I have the feel about which one it is. Still checking it…

So you’re suggesting that this issue is known or, at least, expected due to some wayland-thing getting worked on lately?

I’ll definetely try switching to the x11 session in the meanwhile. I hope that is not the issue, cause I wouldn’t be able to easily fix it/find a workaround.
I hope this issue is caused by some gnome extension that deals with the clipboard: I could updated many of them lately. Maybe the latest version of one of them is faulty. :thinking:

1 Like

I was only arguing against

so with Crtl+z the text is NOT completely lost !

You could try, for as long as needed, :slight_smile: to use mouse :smiley_cat: commands. (right clicks and select copy, paste or whatever you need)

so with Crtl+z the text is NOT completely lost !

You could try, for as long as needed, :slight_smile: to use mouse :smiley_cat: commands.

You’re both correct. But please consider how tedious it is to pay this extra-care when copying/cutting/pasting, or simply to change and break your habit in such a way. :frowning:

I’m almost close to conclude that the issue comes from the the gnome extensions.
There must be one extension that breaks the clipboard. The fact is that, even if I disabled all of them AFTER noticing the issue at least once, the issue remains for the current session. Instead, if I keep them disabled, it seems that the issue doesn’t appear.

This trouble is hard to debug because it happens randomly, and thus it requires that I perform a lot of cut/copy/paste. That means that I can test it while in the middle of my ordinary work sessions… My boss wouldn’t be happy to know that my efficiency is interrupted by the need of performing tests on this tedious bug. :\

I believe I will spot the faulty extension eventually, and scold the developer. :3

It is due to a change in some background applications. You are not the only casualty in this. Some applications are now useless and need rebuilding. But as always all will end well. :wink:

This may be of interest:

1758873 – Regression: X selection buffers are not available to Qt applications

1 Like