Copy paste not working after upgrade to Fedora 31

After upgrading from Fedora 30 to 31, copy-paste stopped working.

When I press Ctrl+C in gedit, the selected text is copied to the clipboard, but Ctrl+V does nothing, and the Paste context menu is disabled. If I switch to another application then back to gedit, the Paste context menu is now enabled and Ctrl+V pastes the text that I copied earlier.

I’m not using any clipboard manager or gnome-shell extensions that affect the clipboard as far as I’m aware.

Update: Works fine on Xorg, it’s only broken on Wayland.

Hi @dan.berindei welcome to the forum.

Comment that I have not this issue with wayland, (There was a bug related with copy/paste between Qt apps and Gtk apps but it was long time and get solved.). if you did recently upgraded to fedora 31 check for new updates and reboot.

If you did check that there are not available updates and not pending reboot. you can try create a new user to check if the issue persist or it is just related with your users files.


There are a few bugs about this, seems to be a Wayland/Mutter related issue. At least some were fixed, but I’m not sure what the status is now:

I’d see which one you are hitting and comment there with whatever information you can provide.


I had this problem after installing Fedora 32. It seems like selinux policy is preventing copy and paste from working. The default mode for selinux is ‘enforcing’. As a workaround, I temporarily changed the selinux mode to ‘permissive’ and now copy and paste seem to work normally.

sudo setenforce permissive

There is probably some security reason why copy and paste are disabled, but it is very annoying. I’m not familiar enough with selinux to change the policy for a permanent fix.

1 Like

I’ve faced the same problem in fedora 32
I’ve solve it tough.
Right click the clipboard icon, select Preferences, select History tab, uncheck “Purge history after timeout”. So far this seems to have worked for me.