Fedora 32: copy/paste issues

Hi all,

I upgrade from Fedora 31 to Fedora 32 and now copy paste is not working !! with Fedora 31the OS was to slow when I open two intelliJ and 10 tabs in chrome, I have 8 GB of memory, and now with Fedora 32 the simple compy paste is not working and I dont have any clue about this !!, please can somebody help me ?

Hello @danfedora

Nice name you’ve got there. Welcome to the Fedora community.
You need to give more information about your issue. You want to copy from what to where? The more we know about the problem, the greater the chances of resolving it.

Hi Thanks for you reply !!, if I want to copy from any place to any other place a text, lets say from a web page that I open in chrome, I choose the text inside the web page then I do ctr+c or right click with the mouse and click on copy, then I go to my text file and press ctr+v or mouse right click paste, but nothing is copied. I am using Fedora gnome -Xorg. I could not pass an interview because I wrote my code in IntelliJ then I could not paste in the web page of the code interview or in an email !!! It never worked copying and pasted from a text file to the ssh terminal, but now It does not work at all. any help is welcome !! thanks again !!

Hmm, I have heard at one time (in the recent past) that the design in Gnome was to prevent Copy/paste from web-browsers. I’ll wait for someone to confirm or refute this

No, nothing of that sort. Some folks have seen copy-paste issues in Qt based applications in gnome, but that’s all.

@danfedora: are you using a clipboard manager by any chance? That’s known to break copy-paste sometimes.

Can you please list the exact steps in detail that you’re following to copy-paste, and can you please look at your journal to see if there are any errors there related to this?

1 Like

Hmmm, I suspected something like that. Same issue here. I warn you, if I don’t get it working I will… switch to KDE (LOL, I switch desktops like other folks change socks anyway, I love Linux).

I had to move from gnome to KDE, then KDE had even more issues, I could not open the settings, and I could not access my network settings, and some times the console did not open. and the network connection was not connected after reboot the machine and I did not have access to the settings to fix it, and from command line I did not explore, that should be possible. IT was too frustrating, not sure what happened here, at the end I was switching to different desktops until I found LXQt Desktop which is working fine although I dont like it too much but I can work.

and it was working fine just soddenly it stops working .

I tried to change the clipboard manager as I was using the default one, but then It got worst.

I hope someone could help us to solve this or to guide us how to get in to the issue as I liked a lot my fedora with gnome :(.


My suggestion would be: just go back to gnome with the default settings that the Workstation ISO has and not use a clip-board manager for the time being. If you do want to use a clip board manager, you’ll have to research them and see which ones do not have these issues.

1 Like

Thanks @FransicoD for your answer, do you have some tutorial or something to follow to go back to the default genome settings that the Workstation ISO has to avoid using any clip-board manager?


1 Like

No, not really. The workstation does not come with a clip board manager, so you just need to uninstall the new clip-board manager you installed, and if you want a really clean system, you can either create a new user or in extreme cases, reinstall the OS.


For those finding themselves with problem to copy from Firefox to Terminal, it’s a Wayland problem.
To avoid it, just disable Wayland at /etc/gdm/custom.conf uncommenting #WaylandEnable=false and reboot.

1 Like