Cut and paste disabled in fedora 30

Hi All,
After installing fedora 30 and login into gnome desktop for the first time, I remember a dialoge box or GUI which asked about what I think is cut and past, or clipboard options or something and something about insecure passwords. I didn’t pay much attention but I believe I clicked on the yes button. Whatever the case may be, at this point, cut and past has been disabled on my desktop and I need it back. I’m having a hard time figuring out how to re-enable cut and past. Any ideas? Thanks.

Hello @stephenadler ! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Talking about your issue, just a clarification: cut and paste doesn’t work with keyboard (ctrl+x ctrl+v) and neither with the mouse?

1 Like

I understand the ctlr+x vs ctlr+v does not work in gnome terminal. The issue I have is when I highlight a section of text I want to cut from a gnome terminal, the highlight will disappear. Usually one can cut and paste with the middle mouse button. You left click + drag to highlight, then you can move your mouse over to a new window and click the middle mouse button to paste. That stopped working in this one installation of Fedora 30. Same goes for firefox URL fields. I try and highlight the URL of a website in the url field and then the highlight disappears within a few milli-seconds. that’s my problem. thanks.

This actually works with ctrl+shift+c ctrl+shift+v, as you may know.

My question was: cut/copy and paste doesn’t work at all with keyboard and with mouse as well?
Btw your issue is that the highlighted text is not being copied, right? :thinking: Strange. Do you have some gnome extensions enabled?

1 Like

I’ve never seen an option or spoke like that during gnome initial setup.

Looking around, a place where middle click is mentioned, is in gnome tweaks (dnf install gnome-tweaks).


What about your configuration?

1 Like

Thanks for the replies guys. I don’t believe it’s the middle button paste option. The signature of the bug is that when I highlight text, by left mouse button click + drag over text that I’m highlighting which I want to copy and paste, after I move the mouse out of the highlighted text, the text highlight goes away. In normal operation, the highlighted text stays highlighted as I move my mouse out of the window over to the other window or field I’m going to past the highlighted text too. The only way I can show you guys is by doing a screen movie capture. The problem is my system at work so I won’t be able to show you until tomorrow when I plan to go back in to my office.

This happens to me sometimes if the terminal is active—as in something is running there. So, when the terminal is updated/refreshed to show new activity, the highlighted bit is gone. It should not happen in a static/inactive terminal though. If it’s happening to you all the time, this is worth reporting as a bug.

Could you try a different terminal emulator in the meantime? That’ll tell us if this is a gnome-terminal issue or not.

I use the terminal via byobu + tmux. There, one can “freeze” the terminal using ctrl + alt + [ and so on, which also works if something is activitly running in the terminal (like htop).

Hi FranciscoD. This is a general cut and paste problem. It occurs through all applications. I have two Fedora 30 installs, one in which this problem occurs one one in which it does not. I use gnome terminal, but trust me, this is not just a gnome terminal problem. If I try and cut and paste text from a web page in firefox, the same problem happens. The highlighted text disapears after 1 second.

As it turns out, the screen cast that I made cannot be uploaded. I’m going to upload it to youtube

The first youtube video shows the copy paste working fine. The second one shows the broken copy past. In the second video, where it’s not working, I was able to get one copy and paste to work. I was able to move the mouse over to the bottom gnome terminal and click the middle mouse button before the highlighted text disappeared. But the rest of my attempts failed. I even did a listing in the top gnome terminal and tried to copy and past the text from some file listings into the bottom gnome terminal, and that failed.

Anyway, this is as best as I can describe this problem. I hope someone can figure this one out…

Have you either received an answer or found one for this issue? I have the same problem with Fedora 30, and find it inconvenient to retype text from websites or the terminal system.

I submitted a bug report 1714334 – "select" function stopped working after last update on May 24, 2019 but have not received a reply.

BTW, it works correctly on Fedora 30 Cinnamon spin.

Which terminal are you using?

In Gnome Terminal I highlight text with mouse and press:
Ctrl-Shift-C to copy.
Ctrl-Shift-P to paste.
Ctrl-Shift-X to cut.

1 Like

Thanks for your reply.
Gnome terminal or whatever comes up when I select Terminal from the Cinnamon desktop. Also fails with “vi”. As described above the failure occurs during the “highlight with mouse”

Today I learn Cinnamon does not have their own terminal.

I do not know if Cinnamon shares GSettings with Gnome.

This is a rather silly question: When you open up Gnome Terminal Preferences, is Enable shortcuts in Shortcuts have a check marked?

I ask as I just spent 15 minutes trying to figure out why a computer would not power on. Hint: it helps if it is plugged in. Sometimes the problem is something simple but overlooked.

1 Like

Thanks for your reply. I will check on your suggestion later today. Being in the computer industry for over 60 years, I’m aware that answers to these problems often are as simple as an option that needs to be changed and be assured I spent several days looking for the answer. And if and when I find the answer I won’t be embarrassed to share it.



The only way I can reproduce your issue is if I disable shortcuts.
Since you are having different experiences between Cinnamon and Gnome makes me think it is GSettings which both use. I would see if Cinnamon or Gnome have different GSettings for Gnome Terminal. It may also be possible if both desktops are installed that they may create issues for one or the other.

1 Like

Just completed an installation of fedora 30 LXDE, and had issues with copy/paste. @stephenadler, I’m assuming you’re in the Workstation, but maybe my solution will give you a hint. I clicked the clipboard icon on the lxpanel:

under Settings, deselect Capture hyperlinks only

under History, deselect Purge history after timeout or select a different Timeout seconds (mine was set at 1)

I copy/paste tested in midori (webbrowser), gedit, xterm, lxterminal, vim, emacs.
As @happycat00 pointed out, the solution might be that simple. Like taking your vehicle to the mechanic because of a loud screeching noise - which he can’t solve - only to find, when arriving home, that the pet cat is missing.

Thanks ptrck4193 Making those changes in Cinnamon appears to correct the problem. It may case another but I will look into it and report on it here.

Your comment reminds me of a story I hope they will allow here. A wife left her family in Alabama to visit Paris for 2 months. 2 weeks later she got a letter that her cat had died. She loved that cat and was very upset. She wrote her husband directing him to give the news more gradually, like “Your cat is on the roof”. Two weeks she got a letter that “Your grandmother is on the roof.”

1 Like

I am having the same problem (cannot copy and paste anything, or cut and paste either) in Gnome on Fedora 30.

I don’t know if this issue was happening right after install, as I didn’t try using my pc right after installing, rather the first thing I did was install a bunch of other desktops as I only like using Gnome sometimes.

So here’s what I’ve found out:

-The issue does not happen at all in KDE. (When I am running KDE / logged into KDE I have no trouble at all being able to copy and paste and being able to cut and paste in all programs.

-The issue DOES happen regardless of whether Gnome is running on wayland or X.

-I am not able to even select something to copy in Gnome, and cannot use the right click on a link and “copy link location” option in Firefox (it never gets pasted when I try to paste in into a text editor afterward).

The above mentioned “copy link location” option in firefox DOES work fine in KDE.

I researched online quite a bit and found a lot of mentions of using a clipboard manager program to try and resolve this sort of issue when it is happening. … And that led to finding out more information, though not any solution:

What I found out next is that I could not run almost ALL clipboard managers on Gnome successfully, i.e., what would happen most of the time is, when trying to launch whatever clipboard manager (in the terminal within Gnome) it would appear to run the program (without a crash) in the terminal, but with most all clipboard managers, no GUI would EVER appear at all. And yet, weirdly enough, they all work just fine in KDE.

So, having said all that, I won’t say I know enough to say that there is a Gnome problem happening, I will only say I wonder if maybe there is?

Ok more information:
This problem IS happening on LXDE as well, but not on LXQT, tried changed all the settings (withing LXDE) I could relating at all to clipboard, nothing helps. Problem also does not happen when running an icewm session.
So, Gnome and/or GTK related maybe??
Quite a weird issue this is too, I cannot select anything in leafpad (or most programs) when running in Gnome or LXDE, but no problems, in KDE, LXQT, and icewm.
Additionally, when running KATE in Gnome, I CAN select text and the selection does not disappear rapidly like with most all other programs. … But… I STILL CANNOT paste anything back that is copied or cut (even in kate) – unless it is done inhumanly rapidly (i.e., an extremely (and I mean extremely) fast ctrl-x and ctrl-y did succeed). But that is the ONLY way it succeeds, EVEN IN kate!

(and tried tweaking settings with gnome-tweaks, no luck there either (program works but changing the settings does not solve the issue what-so-ever!)

This is a different issue, and is probably because they still use the old “notification icon” way of things which no longer works in Gnome. They all need to update to use the status notification specification. I use parcellite, which has the same issue.

More information: