Crackling and Noise on audio recording on Fedora 34 Beta

I clean installed Fedora 34 Beta. On Video Conferencing or on any audio recording my voice crackles and there is a lot of noise. This didn’t happen on my previous install of Fedora 33. I tried replacing pipewire with pulseaudio but the issue still remains. Is there anything more I can do to fix this issue?

It looks like someone has opened a bugzilla report about this problem: 1945418 – Bad microphone sound quality. You can add yourself to the CC list there and if someone posts an answer, you will get notified.

I haven’t tried Fedora Linux 34 yet, but it sounds like the service might not have a high enough priority in the system. If the pipewire service doesn’t get enough time on the CPU, it can “miss” small pieces of audio and the recording will come out sounding crackly. I doubt it would work, but as a workaround/hack you could try increasing the priority of the pipewire service by creating the file /etc/systemd/user/pipewire.service with the following contents (untested):


You’ll need to run systemctl daemon-reload and then restart the pipewire service after creating the above file to test it out.

I tried this but it still doesn’t work. Anyway thanks for trying. :smiley:
I have commented on the bugzilla issue and will provide any information they need on that issue.

If your laptop have a built-in microphone on laptop’s mainboard then the cracking may be caused by incorrect mixing (i.e. the recoding not only recorded your stand-alone microphone but also the noise recorded by built-in microphone).
You can rule out the chances of non-working audio kernel drivers by recoding with your built-in microphone. If it doesn’t crack or produce strange noises (not record-noise but weird bumps), then it’s fine.
You may want to mute built-in microphone when you plugged a stand-alone microphone. If you use KDE you can just find the possible built-in microphone and manually mute it in the sound panel at system tray,

Looks like I found the reason for this crackling and noise.
In Gnome Control Center the input volume was turned up to the max by default. I compared it to my Fedora 33 laptop’s settings and it was less than half on that and there was no crackling and noise on that.
So if anyone is facing the same problem they should first check the sound settings of their system.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.