Control Key not working on Fedora 38 Beta, MacBook Pro (2012)

I have been looking around for a way to resolve this issue for a few days and turning to this thread out of desperation.

The reason I am using the Fedora 38 is because the installer for Fedora 37 did not work correctly on my MacBook Pro (2012).

The issue is that the control key does not seem to be working, I am a complete noob at Fedora and have no idea how to tell if it the control key is mapped as something else but i can confirm via manually trying other key combinations that it isn’t mapped to one of the other keys.

Does the mac keyboard cmd key act as the ctrl key by any chance?

1 Like

Sadly it does not, the command key acts like a super key.

Okay i found out i can view the keyboard layout in gnome, that doesn’t register the control key being pressed so i assume it isn’t mapped (but the Left Command key seems to work despite also not registering in the keyboard layout view)

I found this page talking about input events
Its about mouse events, but it shows how to use the evemu family of tools to view the events.

If you can ssh into the mac and run the tools as you type on the mac keyboard.
Do you see events for the ctrl key?

Just installed the evemu tools on a Fedora VM.
I’m using KDE Plasma desktop and started a terminal session then use evemu-describe to find the keyboard. It show me 2 keyboard devices.

I then ran evemu-record on each keyboard device until I found the one that corresponded to the main keyboard.

As I type I see the events output from evemu-record, it reports the codes and show that I have a left and right ctrl key events.

i don’t have a spare computer to ssh into the system sadly, but i did use another keyboard to see if the control key works on the spare keyboard and it does so I just need a way to try to bind the control key.

edit 1: evemu-tools and evemu-record are not available yet for Fedora 38 aswell as I tried to install them

edit 2: turns out its called evemu-devel for Fedora and i just need to somehow bind Event code 29 (Left Control) to the control key.

edit 3: doing evemu-record does not show any input occuring when using the control key.

edit 4:made edits listed

edit 5:It does appear that in evemu-record that the command key is listed as a “LeftMeta” that is tapped twice if that means anything to anyone

edit 6: I tried Linux Mint real fast in live mode just to see if the problem is there to, and it was if that is also of assistance by chance.

Did you have a look at gnome tweaks → keyboard and mouse → Additional Layout options?
You may be able to modify the layout to what you like there.

If it is not installed it can be installed with sudo dnf install gnome-tweaks

You may also want to have a look at, Apple Keyboard - ArchWiki

You can look and see if any of the options have been set with grep -rF '' /sys/module/hid_apple/parameters/

With gnome tweaks i can turn my capslock into a control key as a stop gap measure so thank you for that!

and this was the outpu for the command to check parameters:


I have a 2012 Macbook Pro running Fedora 37 at the moment. 2 things I had to do to get it to work is download the correct wifi driver and the other was to swap the fn and control keys. In my Linux notes text document I saved this link in case I ever needed to fix it again: Apple Keyboard - ArchWiki

That link will take you to section 4 but I believe section 6 is really what you’re after

While this makes the fn key work as control key the control doesn’t work as a function key when i do this. Thank you for the assist but it isn’t quite what i need.