Non-Functioning Mouse (EDIT: and Keyboard) on Installation, MacBook

I am attempting to install Fedora 30 Workstation, from a USB drive, on a MacBook (Retina, 12-inch, Early 2015, Model 8,1). When the Fedora desktop loads with the install buttons, my mouse (trackpad) does not function. How do I fix this so I can install?

EDIT AFTER FIRST REPLY: I should have also mentioned that my keyboard is not working when the desktop loads either (though the keyboard does work in the terminal from which I load the desktop). I can tell the keyboard does not work because my caps lock has a light, which does not function when I press the key. The only button that functions is the shut-down button.

r3hvmapb it seems your first post in the community, peace be upon those who follow guidance.

I meet an issue before installation which is double click not working.

I suggest that you use button to select until you arrive to mouse settings and change the setting and see how it works, if :ok: continue the installation.

Thank you for your reply and blessing, rtarik.

I should have mentioned that my keyboard does not work either, so I cannot select any button. The keyboard works in the initial terminal, but not once the desktop loads with the install buttons.

Is there some way to fix things from the terminal?

UPDATE: I got the same issue when attempting to install Ubuntu. My keyboard works in GRUB, but my keyboard and mouse do not work when the GUI installer begins. There may be a driver issue. Is there a way I could proceed within GRUB?

I found the issue not related to :fedora: only, have you tried this input driver ?

Thank you, this looks promising.

I am rather ignorant of the basics here, so if anyone has further advice to share about installing this input driver, please post. Again I have a MacBook, Retina, 12-inch, Early 2015, Model 8,1.

How do I accomplish the following? Remember that I only have access to GRUB during the booting process.

Make sure noapic is not in kernel options.

Ensure spi_pxa2xx_platform and spi_pxa2xx_pci are loaded.
If not, rebuild kernel with CONFIG_SPI_PXA2XX=m and CONFIG_SPI_PXA2XX_PCI=m

Ensure applespi driver, spi_pxa2xx_platform and spi_pxa2xx_pci are in initramfs/initrd

As root, do:

echo -e "\n# applespi\napplespi\nspi_pxa2xx_platform\nspi_pxa2xx_pci" >> /etc/initramfs-tools/modules

apt install dkms
git clone /usr/src/applespi-0.1
dkms install -m applespi -v 0.1