Computer doesn't boot

Hello. I’m using a macbook with fedora as unique OS in my SSD. I installed from zero and then update and everything looked OK but when I wanted to turn the computer off, it crashed and I had to force by fiscal button. When I tried to start, the os didn’t start. I can turn on the computer and see the screen of choose the OS but when I choose it doesn’t start. This error it’s not only with fedora, I tried to start other OS from USB and showed same error, so I don’t know what happened and how to fix.
Can someone know the reason?

IDK if I can help, but what model Macbook are you using and are you using rEFIt, rEFInd, or some other Mac specific boot tool?

What happens of you hold OPTION when you boot?

I have a MacBook 2009 late. I’m not using rEFIt, rEFInd anything both.
I’ll show by photos my problem.
here you can see the principal menu to choose operative system. I have tails (USB) and fedora (SSD)

Them shows this (I choose tails from USB

When I choose fedora shows this (apparently normal)

But last only shows a black screen with a “__” in it and looks crashed

Then I cannot do anything

Do you see this screen automatically at boot, or only when you hold down OPTION? What do you see if you do not press any keys on boot?

Also, if you have not already clear your PRAM ( “Option-Command (⌘)-P-R” on boot until you hear the “chime” twice).

You may read up on rEFInd The rEFInd Boot Manager: Getting rEFInd


OMG thank you so much!! I didn’t know about PRAM!! I could start. Thank you so much!! By the way do you know why it happened?

1 Like

Cool, I’m happy it was that simple. PRAM contains (expected) startup disk selection. Clearing it means on next boot it must figure out what will be booting (and make that the new default to look for).

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.