Install 37 on mac means computer can't boot at all

Hi, I’m looking for some help with an install of 37 on an older (2013) imac. (I do currently run 37 on another imac that was upgraded from previous versions and is great).

I tried to install and was having a bit of difficulty with a fresh install over the existing osx. I am not sure what happened but now the computer will not boot.

The initial splash screen says “grub 2.06” but only lists “uefi settings”
If this is selected there is an error that concludes with “Boot to firmware setup is not supported.”

I cannot find anyway to make the mac boot to a usb device or anything else. All efforts result in this message. There does seem to be some grub commands that may be available.

Does anyone know how I can get out of this mess?

I am not sure how to make it boot from USB, but there have been several threads recently about inability to directly install F37 on a mac.

In every case I have seen the solution seemed to be to install F36 then upgrade to F37. It seems something about the F37 version of anaconda may be interfering…

Thanks Jeff,

I didn’t look to see of F37 would be fine - I just assumed it would be okay. That was the mistake.

Unfortunately the only thing I can think to do is to remove the hard drive and wipe it and start again (with F36 I guess). If I wipe the HDD I hope this will fix the issue - does this seem right?

Just for sympathy! To remove the HDD on the mac I bought requires me to remove the screen which is adhered to the computer body and seems like a delicate operation :person_facepalming:

You should not need to remove the hard drive to erase it.Boot up from a live usb drive and use Gnome disks or if you have internet install gparted on the live usb and erase it from there.

I can’t find anyway to boot from usb our any thing else. The usual way with the max is to press option key while booting but this does not work and I cannot find any other key option that changes anything either. If someone can tell me some way to do it that would be awesome!

Out of curiosity how did you boot from the USB the first time?

Well prior to trying to install f37 I had a mac that was booting into osx just fine and pressing the option key on start up have me the option of booting from usb.

The difference now is that none of those options appear. I don’t know enough to understand what is happening or why.

It would be helpful if you can post more details of your iMac model and whether you have the hybrid HDD+SSD mass storage.

Try IFixit’s resetting NVRAM and PRAM.

Also try Using Apple Diagnostics to test your Mac.

Your mass storage hardware may have died – I used to work in a group that processed large volumes of remote sensing data. This was hard on mass storage, so I kept a few external firewire drives preconfigured with our environment. These drives worked well on systems with worn-out HDD until we could get HDD replacements, (under warranty) but I don’t know what other HDD failure modes might do.

1 Like

Thanks, I will try NVRAM and PRAM.

The model is a late 2013 imac 21.5" emc 2638
The storage on my model is a standard HDD

Very similar to the late 2013 27inch iMac I use (mine had the fusion drive until the SSD failed). I assume you have a Fedora Live USB key. If you can get to the point where the start chime sounds and press the key to get a list of boot devices you should be able to boot Live F37 and use smartmontools (you may need to install it ) to check the status of the internal hdd. I find it useful to have Fedora fully installed on a USB drive with utilities like smartmontools.

I did have a live USB key but I have not found a way to access it. I am getting a chime but pressing option or any other key has no effect. I have also tried resetting the PRAM following your advice but it also didn’t work - it just boots to the same grub screen. I tried several times and I’m using a wired apple keyboard.

I have ordered an SSD hoping that replacing the HDD would change something but I am worried that it might not.

I assume grub shouldn’t be where ever it is and if there was some way to erase it something else might happen but I just don’t know enough. I do feel a bit let down that F37 could to this to my computer and it seems that was known!

There should be several startup key combinations available at boot, even with a dead HDD. To get Startup Manager you need to continue pressing the Alt key until the Manager appears. If you can’t get Startup Manager or Diagnostic Utility the system may have a more serious problem than just a failing HDD.

Is your keyboard connected directly to the iMac? Try pressing and holding the Alt/Option key before pressing the power key. Try a different keyboard – a generic PC keyboard should work.

Hi, yes this is what I fear.

No matter what I press I hear the chime and then it goes very rapidly to a grub menu with only the one option described above, which gives an error.

I am using a wired mac keyboard plugged directly into a usb port and I have also tried with the other apple keyboard that I have (and am currently typing on). All the key combinations listed at the page you give, pressed from before I press the power button until I get the menu, have no effect at all.

I cannot explain this but the opening of the grub menu seems to superseded or override any of these options somehow or the computer is no longer receiving input from the keyboards / usb ports.

The only thing that could have triggered this is the attempt to install F37. Nothing else has happened to the computer that was previously running osx without a problem.

I have ordered a ssd drive so I may have an expensive external drive soon!

I’m assuming the HDD is being accessed because the grub menu is coming up. Is it possible that this being loaded, when and how it is, is somehow blocking other startup options and access to usb ports?

I guess I am hoping that replacing or wiping the drive will somehow solve the problem.

Makeuseof has some suggestions for recovering from older Mac boot failures.

What options do you get with the grub menu? Can you use it to boot from an external drive (e.g., Fedora Installed on USB)?

Hackintosh people have lots of information on Mac boot procedures, building bootable drives. etc.

Hi, sorry for the delay in replying.

The only option from the grub menu is:“uefi settings” & if this is selected there is an error that concludes with “Boot to firmware setup is not supported.”
That’s it.

Does anyone know if there is there a safe version of Fedora to install on a 2013 intel mac?

When installing Linux it is important to do your own research for issues affecting your use case. Windows PC’s often use chips for wifi, sound, etc. that don’t have linux drivers. Linux has been removing older drivers that are not being maintained. Apple has a history of inventing new boot mechanisms. With Apple and Microsoft, a new system generally provides a working configuration. With Linux, you have to search for reports of problems for your hardware and choice of distribution. Linux Hardware is an excellent resource, as are the distribution forums.

As mentioned, I installed Fedora 36 (dual boot configuration with Catalina) some time ago, then upgraded to Fedora 37. I used Apple Disk Utility to shrink the macOS partition, leaving free space for Fedora 36. The Startup Key combinations for Startup Manager and Recovery Mode are working.

Is it possible that the uefi settings depends on something stored on the disk unit, for example in a partition dedicated to the firmware? I suggest to ask Apple Mac expert if that is the case and how to fix it.