CommBlog subscribe by email link seems to be broken

See here: Follow with email – Fedora Community Blog

1 Like

That’s not how this is supposed to work. I’ll take a look.

1 Like

Fixed! The option was disabled in Jetpack. It is now enabled.

1 Like