Cleaning / Remove broken Packages

When I run sudo dnf update…I get the following readout in Terminal, In addition to the current updates, I get this message as well.

Skipping packages with broken dependencies:
python3-proton-client noarch 0.7.1-3 proton-fedora-33-unstable
49 k
How can this be cleaned / removed from the system? It has been there since Fed. 34 upgrade.

Any ideas or suggestions?



1 Like

That indicates that the python3-proton-client package from the proton-fedora-33-unstable repository is broken, because it has unsatisfied dependencies. You can remove the package and disable the respository:

sudo dnf remove python3-proton-client

To remove the repository, remove the corresponding .repo file from /etc/yum.repos.d.


Hi Ankur,
Thanks for your reply, but I am afraid that that is not the solution to my problem.
Here is a response that I received from Scott Williams concerning the same problem;

If you’re no longer using this for anything, try removing it: dnf remove python3-proton-client

If you are using this library, consider installing it in a virtualenv with pip after uninstalling it from dnf."

When I did the “dnf remove python3-proton-client”… It removed the present, new version of Proton VPN. That is not what I want to do. I had to re-install

it again. Plus the old “broken package” was still in the system.

Considering the following;

To remove the repository, remove the corresponding .repo file from /etc/yum.repos.d. I’m don’t know how to do that, could you give me further instructions, if possible, if you think that will help?



1 Like

If it’s being used, you need to keep it. The fix here then is to contact whoever is providing you with the package (the people providing the repository) and ask them to fix their package.

I think you should leave the repo installed if you are using the package it provides.

If thats the name of the repo then

sudo rm /etc/yum.repos.d/proton-fedora-33-unstable.repo

should work

Hi Straycat,
I entered this in Terminal;

$ sudo rm /etc/yum.repos.d/proton-fedora-33-unstable.repo

Response was;

rm: cannot remove ‘/etc/yum.repos.d/proton-fedora-33-unstable.repo’: No such file or directory.

Latest Printout from Terminal:

$ sudo dnf update
Last metadata expiration check: 2:01:54 ago on Mi 01 Jun 2022 16:55:36.
Dependencies resolved.

Problem: cannot install the best update candidate for package python3-proton-client-0.7.1-2.noarch

  • nothing provides python(abi) = 3.9 needed by python3-proton-client-0.7.1-3.noarch

You can check your repos in /etc/yum.repos.d . It’s in Nautilus other locations computer.Find the repo then adjust the command in the terminal to remove it.You can also open Gnome Software and disable the repos you don’t want or need.

Hi straycat,

When I ran GNOME Packages I got the following; see attached print screen.
At this point, I don’t know what to do with all these packages with Fedora 33?
Can I remove them all without damaging the Fed. 36 version? and if so how to remove them, safely?
Also, I looked in Nautilus other locations computer, but didn’t find repos… Am I missing something?



You need to click on computer icon then click on etc then click on yum.repos.d. That’s where the repos are.As far as leftovers from F33 have you ran sudo dnf autoremove in the terminal to see what it shows.

hi straycat,
I ran sudo dnf autoremove and it showed 21 items in red, so I removed them. Fedora 33 unstable was not on the list.
I found the old Fed 33 repo’s in the etc folder. See Attached print-screen.

Interestingly, when I run sudo dnf update now, the readout “skip one broken package” doesn’t show up any more…
I don’t know what happened to cause that, but it is a step closer to “peace of mind” concerning unnecessary things.
So now the question is, can I remove all the old Fed 33 unstable repos and how to do it safely?

Thanks for your continued patience / support.


Hi straycat,

See printscreen results when I ran Search Fedora 33 in Terminal.

The second attachment is an older photo when I start the system.

The readout is still the same now (running Fed 36) concerning Fedora 33 (rescue) Workstation.
This is also not necessary or required so how can this also be removed?



The repos you saw in /etc/yum.repos.d you can adjust the command I typed in earlier
sudo rm /etc/yum.repos.d/XXX with XXX being the full name of the repo you want to remove.So if you want to remove fedora-33-unstable.repo
sudo rm /etc/repos.d/fedora-33-unstable.repo is what you type in the terminal.


When I type in Terminal as you suggested, I get the following;
“$ sudo rm /etc/repos.d/fedora-33-unstable.repo
rm: cannot remove ‘/etc/repos.d/fedora-33-unstable.repo’: No such file or directory”.
I tried it with a few of the etc files and they all give the same answer, “no such file or directory”.

What would be a next possible step? Is it possible just to put them in the trash / delete them?




the command to remove it is
sudo rm /etc/yum.repos.d/fedora-33-unstable.repo
I seem to have left out the yum part.You can also use nano in a terminal to disable the repos
sudo nano /etc/yum.repos.d/fedora-33-unstable.repo
then change the part in the file from enabled=1 to enabled=0

Hi straycat,

Now we have made some progress. After your “self correction” I was able to remove some packages from Yum repos.
There is still just this: Fedora (0-rescue-fbed4a9a62574057b9a3581ffa77db8a) 33 Workstation Edition. on startup.
It comes under the three Fed.36 Kernels. Can this be eliminated, as it is “old hat”, and I take it, non-relevant.

Just an other slight (maybe) typo on your part…

sudo nano /etc/yum.repos.d/fedora-33-unstable.repo
then change the part in the file from enabled=1 to enabled=0 I take it enabled=1 to DISenabled=0 or am I wrong?

By the time I was finished doing the (3) rm’s there was nothing left in nano to change.

Thanks again for your persistence and patience with my lack of knowledge.

I like Fedora even though I am not all that Tech. savvy. But I am slowly learning more and more.



Your very welcome and yes your right enabled=1 to enabled=0 I take it enabled=1 to DIS enabled=0 .As far as the rescue mine still shows Fedora 33 as I’ve upgraded from 33 to 34 to 35 to 36.I’ve never bothered to see how to change it.

I just opened etc yum and somehow the “” folder showed up again, after it was gone with the last rm action.
I just did another rm and it disappears. So how and where it goes and what it does when it’s gone is now a mystery to me.
I also now know that Fredora 33 rescue is not just on my PC, you’ve got it as well. Yes its also been there from Fed.33,34,35,36 Have you ever found its location?



Once it’s removed it shouldn’t come back.That’s one someone smarter than me will have to answer.As far as the rescue I’m pretty sure it’s in the /boot folder.You can always just disable that repo with the enabled=0 .