Fedora removed dnf/yum, can the system be fixed?

While updating from 30 to 31 my system shut down, leaving my system on 30 with packages from 31 installed. After trying to remove the duplicates I somehow ended up without dnf and yum and thus unable to connect to a repository and/or update. Can anything be done to save the system? I tried installing dnf with rpm but every package needs at least three others and so on – it seems endless. It would be great if I could save the system somehow. If I could get dnf to work I’m sure I would be able upgrade properly.

1 Like

You can install local rpm packages with the ‘rpm -i’ command, I assume you can download dnf and it’s dependencies from the repository (manually) you can navigate to that directory and use ‘rpm -i ./*.rpm’.

Actually as your install crashed after downloading the packages try going to your cache and running the above command there.

Hi @herakleios—welcome to the forum. Please read the posts in the #start-here if you’ve not had the chance to do so yet.

As @andrewnet said, theoretically, the system can still be saved and it is worth a try. However, it may not work. So, I’d recommend you back your data up and be prepared to fresh install just in case. The best system is to have a separate /home partition so that when you re-install, it can just be mounted and you’ll still have your user data even if you reinstall.

1 Like

Thanks. I believe Fedora creates a separate /home by default but I could be wrong. The Laptop I have Fedora installed on is pretty much just a hobby/backup system so it’s not as crucial anyway. It still would be less trouble saving the existing system, of course.

But trying to install dnf even from the backups leads to missing dependencies, which I could search and download by hand, but then again those four to six dependencies require four to six dependencies as well and so forth, so it’s pretty much endless. Installing everything from the cache didn’t work either as a lot of dependencies are missing, strangely.

Well I guess it’s easier just to delete the system and reinstall Fedora, once I figure out how to create a bootable USB stick on macOS 10.15, as both unetbootin and the Fedora-Media-Writer won’t work under Catalina. I guess it serves me right for giving up GNU/Linux as main OS. :wink:


Yeah if it’s a setup with minimal changes made to it (no big applications made from source etc.) it’s almost always fastest just to reinstall. Use a respin if you want to minimize updates needed. I’ve tried to do offline package installs on various distros it’s pretty frustrating haha. Endless dependencies.


downloading the missing packages should be the first try.

on an fresh installed F31 I got with

rpm -qa | grep dnf | sort



according to the above list get/search them from/on:
and here
and here

best is to stay with the above version numbers, cause this is the set of an full working box !

when downloaded do an

rpm -Uvh *.rpm

Thank you for your comment. I have done this already as advised above. Those dependencies can’t just be installed, as they require further dependencies (except libdnf, as far as I remember), and this deps need further deps and so on. Thank you for taking your time, but I guess I will just reinstall, once I get a bootable USB drive.

Ah, sorry, it’s pretty late here and I haven’t read your post carefully. With those links I seem to get the whole set of .rpm needed. I will try this tomorrow.

yup,but don’t invest too much time after one try, NOT more !

according to what you have removed it’s way better to do an new install and to be on the save side.
the danger is that trouble may come up later caused by broken/lost packages which are currently not that obvious.

maybe you are able to fetch mediawriter from koji too to build an usb stick on your (broken) box.

good luck.