Failed to load /etc/yum.repos.d/fedora-33-unstable.repo

every time i try to update to Fedora 34 or other software the message :

<Failed to load /etc/yum.repos.d/fedora-33-unstable.repo> : “The keyfile does not start with a group.”

Can somebody please help me fixing this problem ?

1 Like

Can you post the contents of that file, please?


how do I get into the content. By the Terminal ? And where do take the screenshot from ?

The message occur every time I want to install or update an app

That repo was installed on my system when I tried protonvpn.

If you do not use protonvpn the message can easily be disabled by the command

dnf config-manager --disable fedora-33-unstable

You also can disable the repo by hand if you use an editor (using sudo) and change the line that says “enabled=1” to “enabled=0”

The content of that file can be seen by doing as I did below. Please compare it to yours and let us know if there is a difference.

# cat /etc/yum.repos.d/fedora-33-unstable.repo 

I have no clue why the message would claim anything about a group.


Offcourse! Now I remember. Yes the problem showed up after trying to install ProtonVPN in the Terminal. There where no Fedora version. Only Debian supported. I took the chance to walk out on thin ice by finding some similar guide. And then I was stocked on the halfway with this message. I will try you advice now and then reply later.

1 Like

Terminal warns that it can not read it. An error message telling that no matching softwarearcive to change : Fedora-33.unstable

This command need root access.

Try run with sudo .


did try that as well.
Thank you


When I search the path in the finder nothing appears.
Is there an other command or way to find it ?

I do not know which is the keyfile of that libary of /etc/yum.repos.d/fedora-33-unstable.repo . Problem is that I’m stocked. Can’t update to Fedora 34 or other software packages

dnf -q repolist
1 Like

When I type in dnf -q repolist in the Terminal console I get this answere:

Is Bravebrowser somehow dominant and blocking for updates. Or how should I understand this reply in my Terminal ?

1 Like

The repo is good, but it seems the .repo file is not correctly formatted so it is not getting read by dnf. I tried it but now do not use the protovpn service so it does not bother me

1 Like

Go back to the stock Fedora configuration. By that I mean disable all repos that aren’t the Fedora default. At that point dnf should work without issue. Once things are working as expected you can begin to re-enable the additional repos, one by one. At some point your error will come back. Now you’ve found the problem repository and can deal with it.

The more I read the original post the more my opinion changes.

Disable all but the stock Fedora repos. Check to see if dnf is now working without error. If so, upgrade to Fedora 34. Once the upgrade is complete you can begin to bring your third party repositories back in.

In my experience with upgrading Fedora, it never goes smoothly if third party repos are enabled, including rpmfusion.


I think I found the problem…

sudo dnf config-manager --disable proton-fedora-33-unstable


Is there an better VPN service which fit Fedora OS ? I did try to install Wire guard ( as it seems to me to be in the open source family. But I did not succeed. It could also had an influence of the descibed Repo problem perhabs.

1 Like

Wireguard is very easy to configure with Fedora.

You just need a VPN service provider that is offering a WG connection method.

“Build a virtual private network with Wireguard - Fedora Magazine” Build a virtual private network with Wireguard - Fedora Magazine

“Configure WireGuard VPNs with NetworkManager - Fedora Magazine” Configure WireGuard VPNs with NetworkManager - Fedora Magazine


Lovely. Thank you Sampson. I tried to search for WG. Does it means Wireguard and as I read is it kind of protection for outgoing trafic from your ports. Or am I wrong ?

I didn’t read the links you just posted yet. And first have to solve the problem of disabling my plugins from thirdpart. So I can update to Fedora 34. Will have a look at it in the last round of reinstalling.