Character Typing Issue


First things first. I am a new Linux user.

So far so good apart from one small thing. I type in a language that requires plenty of accents (é or á or è for example). I am using the alternative character key which is set in Gnome settings to do this and this works great,

However, for some reason when I type a character that is a pre-cursor for a special character, it will always appear. This is endlessly annoying when I am just trying to use punctuation.

Apologies if this is a stupid question and easily answered but I can´t find relevant information on this. I have hopefully attached screenshots illustrating my issue.

Edit: how do you enter the backtick character whith it being taken as a meta character?

If our keyboard type is with dead keys, you can type in the sequence "`a" and get "à". 
To type in "`a" you have to type in "` a" ("`" space "a").  Usually the dead keays are
` ' " ~

In my keyboard I have no dead keys, but I have defined a compose key, so to enter “à” I hit the compose key and type “`a”.

An example of a keyboard with dead keys is the US international variation.

1 Like


Yes, that is exactly what I am looking for. Is it possible to disable dead keys in regular typing and activate it with the right super key?

Had a quick search and couldn’t find anything helpful but will keep looking after work.

You can switch to a keyboard type with no dead keys. You do that in the Settings->Keyboard where you can add additional keyboard. Without knowing which one you are currently using, that is all I can say.

1 Like

Thank you very much for your help. I hadn’t realised that some keyboards do and don’t have dead keys. This is where I went wrong.

Thank you very much for your help super helpful.