Change default language to login fedora

I installed Fedora with default language “ru”.
When load Fedora i need:
First: i need to change language from ru to en
Second: After that i can write my password in english language
Where can i change default language to “en”.
I don’t want everytime change language from ru to en

Photo is not my:



1 Like

Hi, to confirm, you want to change the language of the login screen (GDM) to English?

On gnome, this can be done by going to settings > region and language > login screen (top right hand corner).


User2021 wants to work on a computer who is installed in Russian. Now the default Keyboard Layout should be permanent in English … not Russian (the picture is not from User2021).

Lately i wanted to do something similar in Gnome and i not could figure it out.

In Mate Desktop this seams to be much easier and everything on the same place like:

Is it necessary to install gnome-tweaks for this kind of changes?

Have either of you tried settings > region and language? Does that not work?

I work on a Gnome installation where i installed Mate on top. So all the changes i make are keeping in both environments. But yes I checked it (I do just have one Layout).

What i miss is that everything is on the same place … where can i set that my coma gets a dot on the numeric keyboard section?

@user2021 has two layouts … so maybe he has to put the default just on top (first position). On the gear icon it is also possible to say “Separate layout for each window”.

I’m afraid that’s a different conversation, one that should probably be made with the Gnome design team.

On gnome, you switch layouts using ctrl + spacebar. I use it to cycle between 3/4 different layouts. Works very well.

Anyway, @user2021 can you please comment to confirm if your issue is fixed?

1 Like

As you use 3/4 layouts … is it so that the top one is default right ?

I guess so? I haven’t logged when using an alternative one to see if it persists when I log back in yet. I’ll try that later.

1 Like

This is work for gnome with login in user.(login inside)
This is not work in Gnome Display Manager

Maybe this helps:

1 Like

Even the option that says “Login manager” in the top right hand corner?

I have the same issue with Fedora 35. And no - there is no option in the top right of the settings window:

Is your user an administrator? Here’s what I see on my F35 system now:

@ankursinha I’m also on Fedora 35, and I didn’t see “Login screen” button, same with administrator user :pensive:

1 Like

Did anyone try ibus-typing-booster, switch keayboards and languages.

The button pops up if you have more than one user on the machine. It’s trying to be smart here, so if it’s only one user it matches the login settings to your usual settings :smiley: .

So, create a new dummy user, and it’ll pop up.