Caps Lock and behavior on Numbers Row in French Layout Keyboard

Hi to all !

On Fedora Workstation (Desktop or Live), I use a French Keybord Layout: French (alt.) mainly and sometimes French(AZERTY) on my laptop (keyboard without separate numeric keypad)

Gnome Tweaks is installed but it’s Keyboard => Additional Layout Options isn’t doing the trick and I cannot get Gnome to behave as expected

Expected behavior

  1. When Caps Lock is pressed once it should behave like Shift is locked. This should provide “shift access” to the upper row which on a French(alt.) keyboard layout is the row for numbers. One should be able to type numbersand getting these keystrokes: 1234567890 without having to press any other additional key

  2. Pressing Shift key with Caps Lock pressed should “pause” Caps Lock

  3. When pressing the Shift key alone the upper row leads to these keystrokes: 1234567890

  4. Without pressing the Shift key alone the upper row leads to these keystrokes: &É"'(-È_ÇÀ

Issue
Only 3. and 4. is behaving as expected
Whatever setting is choosen in Gnome Tweaks => Keyboard => Additional Layout Options for Caps Lock, when Caps Lock is pressed I do not get for the upper row: 1234567890 but I get instead keystrokes as If no additional key where pressed: &É"'(-È_ÇÀ

Tedious workaround
Whereas if I hold the Shift key pressed I do get 1234567890 for the upper row

Does anyone have the Gnome GUI settings right and even better the gsettings to achieve this ?
Thanks !

Below are the screenshots of the French(alt.) keyboard layout without and with Shift Key

1 Like

I install Fedora 40 workstation on a Framework 13 laptop. I have the same problem, whether on gnome or kde. How to solve this ?
This post seems to point out a similar problem : Caps lock and number line

Same here on fedora slimbook 2 14" … it’s so annoying :confused:

Hi there. This seems to be connected to the way French keyboard layouts work.

I have noticed the following, with GNOME Tweaks not altered (pressing 3 letter keys and the first 3 upper row keys):

  • English layout, no Caps Lock, no Shift lock: asd123
  • French layout, no Caps Lock, no Sihift lock: qsd&é".

This means that with most French layouts, the keyboard doesn’t default to the number keys but rather to the alternate upper keys. I suppose this is due to the fact that many French-specific letters are in the alternate upper row (é, è, à).

So I guess the GNOME Tweaks configs work as expected, only that the modified way of functioning of French layouts make it work as described by you. If you would switch to an English layout, you would notice that the tweaks would have the effect expected.

Maybe you could play around with other French keyboard layouts. For example, French (US) layout works as desired, if you could accept qwerty instead of azerty layout, and the fact that by default numeric keys are active.

Or, you could try the Caps Lock toggles Shift Lock (affects all keys) option, might work with your layout as expected.

I did try this option but I went back, that “shift” everything, shift arrow, shift click, …
So this is not an option ^^
I asked a friend who have gnome and pop! os and a wide keyboard (with number pad) and an other OS with gnome to … and keyboard works as expected (mean caps lock upper case letters and activate number row)

Is your friend using the same French (alt) keyboard layout? Does the French (US) layout not work for you as expected?

If you don’t find your answers here (the question being too specific), you could try your luck on GNOME’s Discourse. If they confirm your expected results, then it might be a Fedora specific issue. If not, that this works as expected, and you would have to search for other workarounds.

It looks like it is a normal behavior on linux vs windows :

And the solution could be :
https://doc.ubuntu-fr.org/utiliser_verr_maj_pour_ecrire_des_chiffres

1 Like