Fedora 39 Caps Lock toggle reversed and malfunctioning

After upgrading from Fedora 38 to 39, I have noticed that the CAPS LOCK is reversed.
This issue occurs on multiple devices I own. A laptop and a desktop computer.

This happens with an internal keyboard (laptop) and an external keyboard (desktop)
CAPS LOCK toggle is reset to correct state when:

  • Logging in
  • Restarting device
  • Locking session
  • Interacting with the Gnome Applications Search

The indicator light for CAPS LOCK on the keyboard for these devices also gives the reversed or opposite state.

My current solution to fixing this annoying bug:
Lock or Suspend session, then relogin OR open Gnome Activities and search for any text

I have not timed how quickly after the solution the issue comes back, but it is a temporary fix that needs a permanent solution.

I have not found any other posts. Has anyone else come across this issue?

Ask me for any further information you may need to diagnose this problem.

2 Likes

My situation is exactly the same as yours. It’s really annoying!

1 Like

Are you using Wayland or X?

In what other way is caps lock reversed? Are you referring to the indicator on password prompts?

I thought I was on Wayland
but neofetch brings up “Mutter” for window manager

If the indicator light on either of my keyboards are off, then CAPS LOCK is enabled. Visa versa

It is in the correct state for any system prompts like password entry and that fixes the issue just like the other solutions

Edit: My mistake. Yes, compositor or something on Wayland and have always used it for Fedora Workstation and Gnome

I Have the same issue too when I restart it goes of but when open laptop after screen goes over it comes back again.

I discovered something, if it helps maybe you can try that too. In gnome tweaks settings if you enable shift cancels capslock behavior it might have fix it. It worked for me. Actually I used both of it but you can just try shift cancels capslock option.
Screenshot from 2023-11-09 15-15-21

3 Likes

Thank you. I have enabled both options for several hours now and it has been working correctly. I will continue to use them and then set this topic as solved on the 10th of November.

Thanks for the pointer Ozgur, this issue has been driving me mad for the last few days.

I’m going to dig around to see where I’d file this as a bug because it’s only just started happening in the last couple of days so I’d like to file a BZ so it’s not lost. Anyone know what component to use for this?

I just started seeing this issue yesterday.

Fedora 39
Gnome 45

Caps Lock off at login screen - no caps
Caps Lock off once logged in - all caps

I have to turn caps lock on once logged in, so caps will behave as if the caps lock is off.

No idea why it just started happeneing. Nothing changed that I can think of.

Anyone figured out why? I see the gnome tweaks “solution” above, but doesn’t really seem like a fix for long term.

I tried it for a week and it worked for me, thanks.

  • Arch Linux
  • GNOME 46

Sorry, everyone. The solution of configuring inputs worked for some time, but just did not feel right! I am sure many others would agree. I switched from Fedora for a few months and switched back for the beautiful 40, but I believe after updating last night, this bug came back onto both of my systems. Laptop and Desktop are experiencing this bug today. This is very unfortunate and as one other said I hope this does not get buried.

A post on another website mentioned this. /r/Fedora/comments/1bqqxpq/capslock_insanity_f40_beta/