Can't set XKB options to switch the layout

I’m trying to use Gnome Tweak util to set Caps lock as my keyboard layout switching shortcut, but apparently neither XKB options does take place, whatever I set there.

Please help.

This seems to address your issue: Does Wayland use XKB for keyboard layouts? - Unix & Linux Stack Exchange

How exactly?
As I said, I changed the xkb option to set the switching shortcut already.
The problem is it doesn’t seem have an affect.

Correct that is expected it does xkb does not work on wayland.

There are points from the article that I linked to that has references to other resources that might have a solution.

But personal I do not know what the replacement is.

Caps Lock is the only one which doesn’t honor the XKB option.
Other shortcuts, such as Ctrl+Shift, work fine there.

I couldn’t reproduce the problem on Ubuntu with Gnome 45.1.
The problem is reproducible on Fedora 39 and 40 with Gnome 45.4 and Gnome 46 correspondingly.
Not sure if it’s Gnome or distro dependent…