Can't mount /home to hdd

I couldn’t install fedora with /home mounted to hdd so I installed with encrypted btrfs subvolumes (root, opt, usr_local) to ssd with dual boot win 11.
Now I want to change /home to the hdd, I add the fstab but it times out at boot, I think I’m missing something obvious but I don’t know what. I’d appreciate your help.

#omit live fs...
sda           1.8T disk                                                                
├─sda1         16M part                                                                
├─sda2      976.6G part                001C1BE21C1BD190                     ntfs       Nuevo vol
├─sda3        4.9G part  /run/initramf 226523c8-c11d-485a-bbbd-b64b32b0a112 ext4 #fedora live iso      
├─sda4        4.8G part                26BA9420BA93EA97                     ntfs       iso_ntfs
├─sda5      243.2G part                E684B3AB84B37C9D                     ntfs       backup_lat
└─sda6      633.5G part                acfcc772-ac87-47fb-804f-39198dda5e93 crypto_LUK 
            633.5G crypt /run/media/li 1f047f1d-d6e9-4522-9481-e67c9335b192 btrfs      fedora-data
sdb             0B disk                                                                
zram0           8G disk  [SWAP]                                                        
nvme0n1     476.9G disk                                                                
├─nvme0n1p1   100M part                6644-C133                            vfat       
├─nvme0n1p2    16M part                                                                
├─nvme0n1p3 246.3G part                E4A64660A646337A                     ntfs       #win11
├─nvme0n1p4   576M part                F6AC6E08AC6DC429                     ntfs       #win restore
├─nvme0n1p5   513M part                727b7711-861c-46e9-aaa3-a1f897ceb6bb ext4       boot
└─nvme0n1p6   229G part                e4454529-d053-4d39-b5c6-5c7f218c41f4 crypto_LUK 
              229G crypt /run/media/li e1b66652-5abe-4284-9c34-d34198ae3a7f btrfs      fedora
sudo blkid
/dev/loop0: BLOCK_SIZE="2048" UUID="2022-05-04-21-43-03-00" LABEL="Fedora-SciK-Live-36-1-5" TYPE="iso9660" PTUUID="5d35d3f7" PTTYPE="dos"
/dev/loop1: TYPE="squashfs"
/dev/mapper/live-base: LABEL="Anaconda" UUID="687ac404-dee6-4bab-8afc-d044bc0eb0bb" BLOCK_SIZE="4096" TYPE="ext4"
/dev/nvme0n1p5: LABEL="boot" UUID="727b7711-861c-46e9-aaa3-a1f897ceb6bb" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="ed2df476-8bb8-ad41-863e-22465373c403"
/dev/nvme0n1p3: BLOCK_SIZE="512" UUID="E4A64660A646337A" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="9b6448b3-fb5a-4735-a666-aaee47233121"
/dev/nvme0n1p1: UUID="6644-C133" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="53b0c962-bb63-4705-bd6a-432eb9593274"
/dev/nvme0n1p6: UUID="e4454529-d053-4d39-b5c6-5c7f218c41f4" TYPE="crypto_LUKS" PARTUUID="536aec7b-8534-4c64-839e-4fb740231935"
/dev/nvme0n1p4: BLOCK_SIZE="512" UUID="F6AC6E08AC6DC429" TYPE="ntfs" PARTUUID="4415261c-6b24-4435-8c58-9ef3b15180f7"
/dev/loop2: LABEL="Anaconda" UUID="687ac404-dee6-4bab-8afc-d044bc0eb0bb" BLOCK_SIZE="4096" TYPE="ext4"
/dev/mapper/live-rw: LABEL="Anaconda" UUID="687ac404-dee6-4bab-8afc-d044bc0eb0bb" BLOCK_SIZE="4096" TYPE="ext4"
/dev/sda4: LABEL="iso_ntfs" BLOCK_SIZE="512" UUID="26BA9420BA93EA97" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b9cd0f03-6e48-4f0a-b36a-9875ac07c1dc"
/dev/sda2: LABEL="Nuevo vol" BLOCK_SIZE="512" UUID="001C1BE21C1BD190" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a65948c0-c3a2-498e-91ab-26bf49c2120e"
/dev/sda5: LABEL="backup_lat" BLOCK_SIZE="512" UUID="E684B3AB84B37C9D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="34540b65-6719-4350-8a48-f734052b7e86"
/dev/sda3: UUID="226523c8-c11d-485a-bbbd-b64b32b0a112" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="Basic data partition" PARTUUID="61e77d82-6ace-46c6-bda6-eb246e4c3ea0"
/dev/sda6: UUID="acfcc772-ac87-47fb-804f-39198dda5e93" TYPE="crypto_LUKS" PARTUUID="b6d785bc-874b-44be-821d-151b85b88415"
/dev/zram0: LABEL="zram0" UUID="fb182990-5c48-4614-988e-55e227edb513" TYPE="swap"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="498c8eb9-a9c1-40fd-9aee-9ae0ef466d8d"
/dev/mapper/luks-e4454529-d053-4d39-b5c6-5c7f218c41f4: LABEL="fedora" UUID="e1b66652-5abe-4284-9c34-d34198ae3a7f" UUID_SUB="d35d477b-3c27-42d7-8933-14743f4c05c9" BLOCK_SIZE="4096" TYPE="btrfs"
/dev/sda1: PARTLABEL="Microsoft reserved partition" PARTUUID="9f5fbf57-f1c3-46ea-8268-d1c5090bb61f"
/dev/mapper/luks-acfcc772-ac87-47fb-804f-39198dda5e93: LABEL="fedora-data" UUID="1f047f1d-d6e9-4522-9481-e67c9335b192" UUID_SUB="c647e937-15b7-4a7c-a5a3-53b8562eb536" BLOCK_SIZE="4096" TYPE="btrfs"
sudo btrfs subvolume list /run/media/liveuser/fedora
ID 256 gen 484 top level 5 path usr_local
ID 257 gen 484 top level 5 path root
ID 258 gen 484 top level 5 path opt
ID 259 gen 478 top level 257 path root/var/lib/machines
ID 260 gen 478 top level 257 path root/home
[liveuser@localhost-live ~]$ sudo btrfs subvolume list /run/media/liveuser/fedora-data
ID 256 gen 20 top level 5 path home
cat /run/media/liveuser/fedora/root/etc/fstab

# /etc/fstab
# Created by anaconda on Wed Jun 22 07:13:20 2022
# Accessible filesystems, by reference, are maintained under '/dev/disk/'.
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info.
# After editing this file, run 'systemctl daemon-reload' to update systemd
# units generated from this file.
UUID=e1b66652-5abe-4284-9c34-d34198ae3a7f /                       btrfs   subvol=root,compress=zstd:1,x-systemd.device-timeout=0 0 0
UUID=727b7711-861c-46e9-aaa3-a1f897ceb6bb /boot                   ext4    defaults        1 2
UUID=6644-C133          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
UUID=e1b66652-5abe-4284-9c34-d34198ae3a7f /opt                    btrfs   subvol=opt,compress=zstd:1,x-systemd.device-timeout=0 0 0
UUID=e1b66652-5abe-4284-9c34-d34198ae3a7f /usr/local              btrfs   subvol=usr_local,compress=zstd:1,x-systemd.device-timeout=0 0 0
UUID=1f047f1d-d6e9-4522-9481-e67c9335b192 /home btrfs   subvol=home,compress=zstd:1,rw,noatime 0 0

First, to ensure that I interpret everything right: Which UUID is of the ssd-home you are currently using, and which UUID is of the timeout-affected hdd-home you want to use?

Second, we need to see the log files of the system because these contain the specific details of the error and its context.

If the error / timeout occurred on the current boot, provide the output of journalctl --boot=0

If the error / timeout occurred on the last boot, provide journalctl --boot=-1

For a full list of the logged boots see journalctl --list-boots which includes the start and end times of the logged boots. We need one that definitely contains the error/timeout.

I have seen before an error that had similarities, it was tackled in this thread:

Depending on the configuration, it maybe needs to be considered that hdd’s have a much slower response time than ssd’s. I will review the disk configuration you provided when I saw the logs.

Thanks for responding. I almost got it.
I don’t know how much obvious it was, but my problem actually was that I needed to unlock the root account. Cannot open access to console, the root account is locked in emergency mode (dracut emergency shell) :: Fedora Docs ( and then I had to add the home partition in the hdd to /etc/crypttab.
This actually gave me the big picture:
LUKS: Swap, Root and Boot Partitions - Infosec Resources (

My problem now is that I can’t login, I get to the login screen but after I enter my password the screen just flashes and nothing happens. I used ctrl+alt+f3 to login to the console and i get this message:

-- raji : /home/raji: change directory failed: permissions denied
Logging in with home = "/".

Maybe the user ID of the user name is no longer the same (I assume you have installed a new system, created a new user with the same user name during the installation, and now added the old home dir of the previous installation?).

Check ls -l /home/ → you will then see owner & group of the user directories.

The owner/group of the respective home dir (/home/‘username’) has to be equal to the username you log in. If this is not the case, or if you just see a 4-digit number (which is the ID), you have to change the ownership/group of the folder recursively, or change the ID of your username in /etc/passwd to the one you see in the home dir.

Assuming that you have created the user during the installation while you now use the home of a previous installation, I suggest to change the ownership of the dir: chown -R <username> /home/<user folder> and chgrp -R <username> /home/<user folder> → be careful with these commands ! They can be dangerous if you make mistakes.

Background: the system works with the ID. Even if the username is still the same, the ID of the last and the current installation can be different. For the system, this implies it is now another user, even if the name remains. So, if you see a number with ls -l, that means that the folder belongs to an user ID that is currently not in use, which means that your user name has obviously now another ID than before.

If this does not help, open a new thread for this.

No, this is a clean install. I wanted to use both disks at installation but blivet didn’t let me because I had the iso mounted on the hdd even though it was in another partition, and with the custom install it just mixed the space from both the ssd and the hdd so i decided to just install to the ssd with 3 subvols (root,opt and usr_local) and then move /home to the hdd.
The home subvolume in the hdd was created post-install and then I used rsync -aR /home/* /mnt/home/ Renamed it to home.old and modified the fstab. Then I posted this question. :stuck_out_tongue:

Ok, I ran the commands, now the monitor goes to no signal

Edit: its black again, still no desktop. I guess I’ll open a new thread but I want to ask about these sub volumes:

$sudo btrfs subvolume list /
ID 256 gen 484 top level 5 path usr_local
ID 257 gen 484 top level 5 path root
ID 258 gen 484 top level 5 path opt
## this three are the ones I created at installation 
ID 259 gen 478 top level 257 path var/lib/machines
ID 260 gen 478 top level 257 path home
$ sudo btrfs subvolume list /home
ID 256 gen 20 top level 5 path home

where did the var/lib/machines (ID 259) and home (ID 260) came from, should i delete the nested home one?

When opening a new thread, also add the logs as mentioned above: we need logs in which the error takes place, and also mention the time when the error appeared so that we know where to look at the logs.

Also, add the output of the ls -l /home and whoami commands. And when exactly / at which action the screen turns black, and what is still possible / not possible.

Thanks I finally solved it!
I don’t know why chown with username didn’t work but what it did was using my uid/gid. I also deleted the home subvolume on the ssd
login to the tty then:

cd /home
sudo mkdir raji2
sudo chown 1000:1000 raji2
#copy the backup to new dir
cp -ar /home.old/raji/. /home/raji2
#replace current folder
sudo rm -r raji
sudo mv raji2 raji

I’ll leave these for reference
fstab - Problem with mounting home partitions - Ask Ubuntu
encryption - How do I move/home folder to a luks encrypted external drive? - Ask Ubuntu

Edit: can’t edit the title but maybe someone can change it for something more descriptive like the latter

The first user created should be in the wheel group and therefore is included automatically in sudoers, therefore you can use sudo -i for this instead of activating the root user.