Can't Install VMWare WorkStation 16 on Fedora 34 Silverblue

I’m trying to install VMWare WorkStation on SilverBlue (Fedora 34) and it’s not working. I’ve moved it from downloads to the Home directory and here are the commands I’ve ran so far:

[liamb-perspvt@liampersonal home]$ ls
bobbyb-fmv  liamb-perspvt  liamdev  VMware-Player-16.1.2-17966106.x86_64.bundle
[liamb-perspvt@liampersonal home]$ chmod +X VMware-Player-16.1.2-17966106.86_64.bundle
chmod: cannot access 'VMware-Player-16.1.2-17966106.86_64.bundle': No such file or directory
[liamb-perspvt@liampersonal home]$ chmod +X VMware-Player-16.1.2-17966106.x86_64.bundle
[liamb-perspvt@liampersonal home]$ ./VMware-Player-16.1.2-17966106.x86_64.bundle
Extracting VMware Installer...done.
root access is required for the operations you have chosen.
[liamb-perspvt@liampersonal home]$ sudo ./VMware-Player-16.1.2-17966106.x86_64.bundle
[sudo] password for liamb-perspvt: 
Extracting VMware Installer...done.
Rolling back VMware Installer 3.0.0
    Deconfiguring...
[#                                                                     ]   1%

[######################################################################] 100%
Installation was unsuccessful.
[liamb-perspvt@liampersonal home]$ 

I’ve also tried running:

$ bash VMware-Player-16.1.2-17966106.x86_64.bundle --ignore-errors

Didn’t work

Lastly, per this post Solved: Re: VMware Workstation installer fails on Fedora 3... - VMware Technology Network VMTN - I’ve tried:

$ bash vmware-installer-wrapper.sh VMware-Player-16.1.2-17966106.x86_64.bundle

Didn’t work

Here's the run/usr/1000/doc/XXXX.log

"2021-09-17T05:00:28.468-04:00| host-15029| I005: Log for VMware Workstation pid=15029 version=16.1.2 build=build-17966106 option=Release
2021-09-17T05:00:28.468-04:00| host-15029| I005: The host is 64-bit.
2021-09-17T05:00:28.468-04:00| host-15029| I005: Host codepage=UTF-8 encoding=UTF-8
2021-09-17T05:00:28.468-04:00| host-15029| I005: Host is Linux 5.13.15-200.fc34.x86_64 Fedora 34.20210915.0 (Silverblue) Fedora 34
2021-09-17T05:00:28.468-04:00| host-15029| I005: DictionaryLoad: Cannot open file "/etc/vmware/config": No such file or directory.
2021-09-17T05:00:28.468-04:00| host-15029| I005: [msg.dictionary.load.openFailed] Cannot open file "/etc/vmware/config": No such file or directory.
2021-09-17T05:00:28.468-04:00| host-15029| I005: PREF Optional preferences file not found at /etc/vmware/config. Using default values.
2021-09-17T05:00:28.468-04:00| host-15029| I005: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory."

no idea what’s going on and trying all of this si where more technical than I actually am. i prefer a GUI very much so and GUI instructios would be greatly appreciated.

I understand Gnome Boxes is great but can’t get it easily provisioned on other Operating systems which is where these will eventually need to move and I’m unfamiliar with Virtual Machine Manager - the other popular Linux VM provisioner - so I’d like to just stick with VM Ware for now. Plus i’ll be testing other stuff with them. Can anyone help? Thanks.

Does vmware work on Fedora Silverblue? I can’t imagine it would given how vmware and silverblue both work. That being said, I have never tried it myself so I can’t say that definitively.

You can’t run all Linux software on silverblue.

I know this isn’t directly helpful but I can tell you that I am running vmware workstation pro on the normal Fedora 34 without issue.

2 Likes

Well, it’s the most helpful so far. I’m beginning to wonder if I should just use Fedora Workstation as the main OS and partition my PC to run Workstation on one side and Fedora Silverblue on the other.

I can build out a raspberry pi and get ESXi up and running on there (just did it last week) but I can’t seem to get Silverblue to work with VMware. My speculation is that it’s really just in the bash script because the VMWare installer aims to install it on the regular root directory and Silverblue puts everything (I believe) layered on top of VAR. I don’t know how to edit this script or where it even is and what I would put to redirect it - because as you can see, it fails at 1% and the logs suggest that as well ha.

I am not an expert on Silverblue, but here is my understanding. Most of it lives in an immutable os-tree structure. Most of the writable sections live in /var and are symlinked elsewhere. However, this is limited to only a handful locations. Most of the filesystem is completely read-only. I am not sure what you could do to make that work with vmware.

2 Likes

There are some tradeoffs between using immutable OSes such as Fedora Silverblue vs the standard Linux OSes.

Definitely, setting up a working environment in Silverblue takes longer; requires an advance knowledge of Linux; a different mindset is necessary since the super user cannot write anymore to system files; not all the Linux universe applications are installable. In certain way feels like a different, hardened Linux.

At the same time, a Silverblue OS is more rewarding: harder to break by a random dependency; gaining a solid installation; able to save working versions of the OS with one line; tight isolation between applications; encourages the user to install applications and binaries in new innovative ways because the core system files are read-only; lower chance that changes made by one user affects another one since the fragile surface is drastically reduced.

There are plenty more pros and cons, of course; the more you dig into Silverblue the higher the chances to find something unique.