Impossible to install virtual box extension pack

Has anyone installed the Virtualbox extension pack in Silverblue? I tried after installing virtualbox from RPM and from repo, using the GUI and the CLI and had no success. because the structure (/usr/lib/…) is read-only the application cannot install it, and I can’t find an rpm to install it with. The message from the GUI install is:


Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManagerWrap
Interface: IExtPackManager {70401eef-c8e9-466b-9660-45cb3e9979e4}


and from CLI is:

VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-*.vbox-extpack
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (5.7.16-200.fc32.x86_64) or it failed to
load. Please recompile the kernel module and install it by

       sudo /sbin/vboxconfig

     You will not be able to start VMs until this problem is fixed.

VBoxManage: error: ‘/var/home/fernando/Oracle_VM_VirtualBox_Extension_Pack-*.vbox-extpack’ file not found
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackFileWrap, interface IExtPackFile, callee nsISupports
VBoxManage: error: Context: “Install(fReplace, __null, ptrProgress.asOutParam())” at line 1360 of file VBoxManageMisc.cpp


Any clue as to what I should do?

Is the following post maybe helpful

1 Like

Hi, and thanks a lot!

I came across this thread before posting the question, I don’t get the impression it is actually about a similar issue, but it could be. It seems it’s dealing with silverblue as a guest, and not a host, which is my case. Anyhow, they don’t post any answer/procedure on it.

I think they are talking of Silverblue being the host.

Does this not work?

1 Like

Installing and running Vbox works, as far as I know, just fine. The issue is, if I try to install Vbox host extensions, to try to use USB3.0, USB2.0, webcam and other things, it is not possible. Vboxmanage tries to install it on the same FS vb is, which happens to be write-only. I tried to force it to RW, but had no success. I don’t believe the people in this thread faced the same issue at all.