Can't connect to wifi - No wifi device found? What's wrong with NetworkManager? (Fedora 37)

With no driver it is difficult to find your hardware.

Can you check there if you get a bit more infos? :

Fedora 37 is listed.

I don’t know if you saw this:

Just to find out which driver version works. I see it is Comet lake but the way to debug seams to be the same.

It’s absurd that during installation of Fedora 37, I was able to connect to wifi AND configure the parameters such as IPv4, IPv6, etc.

No, not until you mentioned Intel Comet Lake PCH-LP CNVi WiFi driver: N/A

It appears that in that post, debugging didn’t help. The OP just tinkered around and somehow solved his issue by chance.

By the way, you may wish to read my reply in that post.

[Sorry for digressing; now back to my issue]

A few months ago, my dad bought a new laptop computer for me on my birthday. It came with the latest Intel 12th gen CPU and Intel AX211 wireless chipset.

Debian 11’s repository of Intel wireless drivers are ancient; they don’t work on machines with Intel 12th gen CPUs and Intel AX211 wireless chipsets. That’s the reason I switched to Fedora 37. (By the way, Debian Bullseye launched on August 14th, 2021 and you can understand why I said that their iwlwif are ancient.)

I agree. In that other thread, I think I received very solid advice on how to investigate the problem. None of that worked for me. But it was still good advice and I would expect that following such advice would usually work.

I wish I remembered for sure (but at that time I was testing too many different Linux things on different computers with various USB media). But as far as I recall, the very first time I was in Linux on that machine, the wifi just worked with no issues: nothing to set up other than the key for my home wifi. Later, the driver wouldn’t load the firmware and I never understood way. Then it started working again.

I was more careful to keep track of what I was doing across that change. So I find it very hard to believe I “somehow solved” it as opposed to it randomly solved itself unrelated to anything I was doing. The driver that worked and the 72 version of the firmware that worked were certainly unchanged from when it didn’t work to when did.

I hope the process goes better for you.

On non-GNOME systems you can use /usr/bin/nm-connection-editor which is a gui editor for network connections.

That is an excellent suggestion. Unfortunately even that is not going to work unless the driver can be loaded, which at present does not happen.

I would suggest that a bug report be filed about this particular issue since Intel provides the firmware and the driver for those cards. Whether it is a driver issue or a firmware issue or a kernel issue is really unclear. I suspect at least part is kernel changes but also the chipset and firmware.

It seems there are constant issues with newer (and sometimes older) machines using the AX211 chipsets where sometimes it works; then it does not; then it may work again. The back and forth has to be frustrating for those affected.

That timing of the change and the fact that the firmware has not been changed in the time period involved seems to indicate it may be more driver or kernel related.

Good point.

Can you be so kind as to provide me the link to file a bug report? Thanks.

Using Bugzilla :: Fedora Docs

  1. Check in Fedora Accounts if you want to use a different email as you use for Fedora it selves. On the link above you have to set your preferred email just for RH Bugzilla or if you want the same as Fedora just fill it up in the RH Bugzilla field to.

  2. Before filing a bug please check for existing Bug/Fixes first.

Please link the Bug after for us too.

Even easier,
Just go to and log in using your FAS account that is used to log in on this forum. There is actually no need to set up a separate account on bugzilla unless you truly want to.

1 Like

The Linux Hardware (LH) database has many entries for AX211 chipsets. They all have 8086:51f0:8086:xxxx ID’s. The 4th number is important. With that you can find the database entries for a particular AX211 chipset.

The other source of confusion is the wide range of use cases. Wifi chipsets generally include bluetooth, so users who need bluetooth may report “not-working” while others who only need wifi report “working”. Other use cases may require 5 GHz or Wifi 6.

My guess is that Intel does triage when deciding whether to port a driver to a newer kernel. Newer AX211 chipsets add wifi 6 support, which is important for organizations that have a large number of wifi users.
Wi-Fi 6 for universities. Intel’s linux wifi driver documents mention only wifi 6 capable AX211, so the current drivers may not support older AX211 chipsets, and the older drivers may not work with the current kernel. The LH database will tell you which
AX211 modelswork with recent kernels.

Unfortunately, the LH database doesn’t capture the use-case side of the problem.

1 Like

I suspect that the minimal approach you took skipped the wifi drivers altogether. What you have made is essentially a server with a desktop. Servers rarely need or have wifi capabilities.

I would try booting back into the ‘everything live’ environment. Then follow some of the suggestions others have made to identify the hardware. Virtually any driver you would need is included in the everything ISO package.

Once you know what hardware you have, you can get the driver from the ISO. I would have to search for how to do that, but I am confident it is worth a try.

I reread this thread and did not note anywhere that you have posted details from dmesg | grep -iE 'iwl|wifi|ax211' or journalctl -b 0 | grep -2 iwl
The intel wifi chipset you have on that wifi adapter uses the iwlwifi driver and will also need the iwl firmware. You can check if the iwl firmware is installed, and what versions with dnf list installed *firmware*. If the firmware is installed you may still find that the driver is not installed since you did not have that adapter active during the install and stated that you explicitly disabled it to install via ethernet. The minimal install only installs the necessary packages and since you did not ‘need’ it while installing it may not be installed.

Try booting back into the live USB you used to install, and repeat these steps. Note the hardware you have, the firmware that works, and the drivers. Do this with wifi and Bluetooth on if possible.
Then reboot into the installed system. Plug in the Ethernet cable and manually dnf install the firmware and driver’s you found. They should work after restart.
These are the pitfalls of minimal installation. A lot of good debugging suggestions all over the thread; but you have to go back to a state where the chipset is powered on.

If ethernet is unplugged when you run the Fedora 37 live USB wifi should be enabled. If the Fedora Live USB doesn’t enable wifi, try a live USB for Ubuntu.

2 posts were split to a new topic: Installing broadcom wifi drivers

@computersavvy @ilikelinux @john2fx @vekruse @gnwiii @kevin-rasco

Hi guys,

I really appreciate the fact that you took the time and make the effort to help me.

But I have decided to give up on using Fedora for the time being until the next iteration, that is, Fedora 38 or 39.

I’d like to take this opportunity to send my best wishes of the season to you and your loved ones.

By any chance were you dual booting when you had this issue? If so, disabling Windows fast startup fixed the problem on my side. More details:

  1. Intel WiFi AX200
  2. For some reason it stopped working in Fedora 37 (kernel 6.1.x) and in PopOS 22.04 (kernel 6.2.x), but no issues in Windows 11

This is the thread from which I found the fix:
WiFi 6 AX200 wireless adapter to work in Debian-11

1 Like

I’ve had the same issue with my adapter. It suddenly stopped working while I was trying to install legacy NVIDIA driver.

I’ve tried many things, but this is what eventually fixed it…

sudo dnf install linux-firmware
sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci

This may have been what fixed it. That is a meta-package that brings in all the provided firmware packages for supported hardware and may have just brought in the needed updated firmware for you.

When you said legacy NVIDIA driver what driver were you trying to install and from what site?

On RHEL9, (not Fedora) I found that NetworkManager-Wifi was not included in a minimal install. I had to connect once more with a wired connection, install NetworkManager wifi, and then it worked, (this is with an in Intel wireless adapter.) If you do
dnf group info "Minimal Install"
dnf group info Core

This was on a T495 an AC9250. I don’t remember exactly now, but I may have, at that time, also had to install iwlax2xx-firmware and iwl7260-firmware (but I think they were installed by the system, not by me)
you can see what is and isn’t included.

A post was split to a new topic: I’m having trouble installing drivers for NVIDIA GeForce 920M