Can't connect to wifi - No wifi device found? What's wrong with NetworkManager? (Fedora 37)

My “operating system” is Fedora 37, 64bit.

[Edited] To be exact, I downloaded Fedora Everything and chose Minimal Install with @base-x and @lxde.

During installation, I identified my network SSID and input the password to connect to wifi. Wireless connection was successful. Next I configured the GUI such that IPv6 is disabled and input my preferred DNS.

However, as my machine was connected to the internet via a wired LAN at the time, I clicked the button to shut down the wireless connection.

Installation proceeded with the ethernet connection.

Post installation, I am now unable to connect to wifi.

In /etc/NetworkManager/systemconnections, there are two files:

Wired connection 1.nmconnection
XYZ.nmconnection (where XYZ is the name of the SSID)

In a terminal, I typed the following commands in sequence:

A. systemctl status NetworkManager

NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: enabled)
     Active: active (running) since 
       Docs: man:NetworkManager(8)
   Main PID: 1210 (NetworkManager)
      Tasks: 3 (limit: 28465)
     Memory: 6.5M
        CPU: 40ms
     CGroup: /system.slice/NetworkManager.service
             └─1210 /usr/sbin/NetworkManager --no-daemon

B. nmcli radio wifi


C. nmcli con show

[username@hostname ~]$ nmcli con show
NAME                   UUID     TYPE      DEVICE 
XYZ                    xxxx     wifi      --     
Wired connection 1     xxxx     ethernet  --     
[username@hostname ~]$

(where XYZ is the name of the SSID)

D. sudo nmcli --ask dev wifi connect XYZ (where XYZ is the name of the SSID)

Error: No Wi-Fi device found.

[Edited] I forgot to add the following action that I took. Here it is:

E. sudo sudo nmcli dev wifi
Result: Blank, no list, no nothing

Thank you for helping me to solve the issue.

Have you tried simply using the gnome control center (AKA Settings) to establish the wifi connection? It the adapter is properly configured it should show a list of SSIDs that you may connect to, and if one of them is yours then select it and connect.

If the list is not shown then there may be something wrong with the adapter config.

Thanks for your reply.

I left out an important piece of information and have just edited my original post to include it.

I do not use Gnome as my desktop environment. In fact, I installed a minimal set of programs from LXDE like so:

sudo dnf --setopt=install_weak_deps=false install @base-ex @lxde

1 Like

You are right.

When I typed the following command in a terminal, like so:

sudo sudo nmcli dev wifi

There is no list, no nothing.

inxi -N would give us the info what you have and what drivers you use.

Here’s the info that you asked for:

[username@hostname ~]$ inxi -n
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: N/A
[username@hostname ~]$

With no driver it is difficult to find your hardware.

Can you check there if you get a bit more infos? :

Fedora 37 is listed.

I don’t know if you saw this:

Just to find out which driver version works. I see it is Comet lake but the way to debug seams to be the same.

It’s absurd that during installation of Fedora 37, I was able to connect to wifi AND configure the parameters such as IPv4, IPv6, etc.

No, not until you mentioned Intel Comet Lake PCH-LP CNVi WiFi driver: N/A

It appears that in that post, debugging didn’t help. The OP just tinkered around and somehow solved his issue by chance.

By the way, you may wish to read my reply in that post.

[Sorry for digressing; now back to my issue]

A few months ago, my dad bought a new laptop computer for me on my birthday. It came with the latest Intel 12th gen CPU and Intel AX211 wireless chipset.

Debian 11’s repository of Intel wireless drivers are ancient; they don’t work on machines with Intel 12th gen CPUs and Intel AX211 wireless chipsets. That’s the reason I switched to Fedora 37. (By the way, Debian Bullseye launched on August 14th, 2021 and you can understand why I said that their iwlwif are ancient.)

I agree. In that other thread, I think I received very solid advice on how to investigate the problem. None of that worked for me. But it was still good advice and I would expect that following such advice would usually work.

I wish I remembered for sure (but at that time I was testing too many different Linux things on different computers with various USB media). But as far as I recall, the very first time I was in Linux on that machine, the wifi just worked with no issues: nothing to set up other than the key for my home wifi. Later, the driver wouldn’t load the firmware and I never understood way. Then it started working again.

I was more careful to keep track of what I was doing across that change. So I find it very hard to believe I “somehow solved” it as opposed to it randomly solved itself unrelated to anything I was doing. The driver that worked and the 72 version of the firmware that worked were certainly unchanged from when it didn’t work to when did.

I hope the process goes better for you.

On non-GNOME systems you can use /usr/bin/nm-connection-editor which is a gui editor for network connections.

That is an excellent suggestion. Unfortunately even that is not going to work unless the driver can be loaded, which at present does not happen.

I would suggest that a bug report be filed about this particular issue since Intel provides the firmware and the driver for those cards. Whether it is a driver issue or a firmware issue or a kernel issue is really unclear. I suspect at least part is kernel changes but also the chipset and firmware.

It seems there are constant issues with newer (and sometimes older) machines using the AX211 chipsets where sometimes it works; then it does not; then it may work again. The back and forth has to be frustrating for those affected.

That timing of the change and the fact that the firmware has not been changed in the time period involved seems to indicate it may be more driver or kernel related.

Good point.

Can you be so kind as to provide me the link to file a bug report? Thanks.

Using Bugzilla :: Fedora Docs

  1. Check in Fedora Accounts if you want to use a different email as you use for Fedora it selves. On the link above you have to set your preferred email just for RH Bugzilla or if you want the same as Fedora just fill it up in the RH Bugzilla field to.

  2. Before filing a bug please check for existing Bug/Fixes first.

Please link the Bug after for us too.

Even easier,
Just go to and log in using your FAS account that is used to log in on this forum. There is actually no need to set up a separate account on bugzilla unless you truly want to.

1 Like

The Linux Hardware (LH) database has many entries for AX211 chipsets. They all have 8086:51f0:8086:xxxx ID’s. The 4th number is important. With that you can find the database entries for a particular AX211 chipset.

The other source of confusion is the wide range of use cases. Wifi chipsets generally include bluetooth, so users who need bluetooth may report “not-working” while others who only need wifi report “working”. Other use cases may require 5 GHz or Wifi 6.

My guess is that Intel does triage when deciding whether to port a driver to a newer kernel. Newer AX211 chipsets add wifi 6 support, which is important for organizations that have a large number of wifi users.
Wi-Fi 6 for universities. Intel’s linux wifi driver documents mention only wifi 6 capable AX211, so the current drivers may not support older AX211 chipsets, and the older drivers may not work with the current kernel. The LH database will tell you which
AX211 modelswork with recent kernels.

Unfortunately, the LH database doesn’t capture the use-case side of the problem.

1 Like

I suspect that the minimal approach you took skipped the wifi drivers altogether. What you have made is essentially a server with a desktop. Servers rarely need or have wifi capabilities.

I would try booting back into the ‘everything live’ environment. Then follow some of the suggestions others have made to identify the hardware. Virtually any driver you would need is included in the everything ISO package.

Once you know what hardware you have, you can get the driver from the ISO. I would have to search for how to do that, but I am confident it is worth a try.

I reread this thread and did not note anywhere that you have posted details from dmesg | grep -iE 'iwl|wifi|ax211' or journalctl -b 0 | grep -2 iwl
The intel wifi chipset you have on that wifi adapter uses the iwlwifi driver and will also need the iwl firmware. You can check if the iwl firmware is installed, and what versions with dnf list installed *firmware*. If the firmware is installed you may still find that the driver is not installed since you did not have that adapter active during the install and stated that you explicitly disabled it to install via ethernet. The minimal install only installs the necessary packages and since you did not ‘need’ it while installing it may not be installed.

Try booting back into the live USB you used to install, and repeat these steps. Note the hardware you have, the firmware that works, and the drivers. Do this with wifi and Bluetooth on if possible.
Then reboot into the installed system. Plug in the Ethernet cable and manually dnf install the firmware and driver’s you found. They should work after restart.
These are the pitfalls of minimal installation. A lot of good debugging suggestions all over the thread; but you have to go back to a state where the chipset is powered on.

If ethernet is unplugged when you run the Fedora 37 live USB wifi should be enabled. If the Fedora Live USB doesn’t enable wifi, try a live USB for Ubuntu.

2 posts were split to a new topic: Installing broadcom wifi drivers