Problems with iwl driver and Comet Lake Wifi Adapter in Fedora 39

Using Fedora 39 in an HP laptop,

The integrated Wifi Adapter stopped working since I upgraded around F37, and seems to still not work.

The problem appears to be:

$ lspci -nn | grep -i wifi
00:14.3 Network controller [0280]: Intel Corporation Comet Lake PCH CNVi WiFi [8086:06f0]

$ dmesg | grep -i iwl
[   17.422985] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   17.427625] iwlwifi 0000:00:14.3: Detected crf-id 0xa5a5a5a2, cnv-id 0xa5a5a5a2 wfpm id 0xa5a5a5a2
[   17.427671] iwlwifi 0000:00:14.3: Can't find a correct rfid for crf id 0x5a2
[   17.427701] iwlwifi: probe of 0000:00:14.3 failed with error -22

$ uname -r
6.6.9-200.fc39.x86_64

Anybody knows how to get it working, or if it is not currently supported?

Let me know if more information is needed.

1 Like

yikes

I am about to upgrade f38 → f39 on a laptop with the same network controller. Currently f38 is running the 6.6.9 kernel and it works.

Do you have the iwlwifi-mvm-firmware package installed?

Linux Hardware Database has 14 models with [8086:06f0], so you need the subvendor and subdevice entries to find an exact match. There may be notes that tell you how to get the adapter working (where “working” may not encompass a use-cases).

I do have that installed:

iwlwifi-mvm-firmware.noarch          20231211-1.fc39                   @updates         

Here is more info about the PCIe device, including susbsystem id.

$ sudo lspci -nn -s 00:14.3 -v
[sudo] password for david.fernandez: 
00:14.3 Network controller [0280]: Intel Corporation Comet Lake PCH CNVi WiFi [8086:06f0]
        Subsystem: Intel Corporation Device [8086:0000]
        Flags: fast devsel, IRQ 16, IOMMU group 7
        Memory at 606311c000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [80] MSI-X: Enable- Count=16 Masked-
        Capabilities: [100] Latency Tolerance Reporting
        Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
        Kernel modules: iwlwifi, wl

There are 4 LHDB scans, all for older kernels and “detected” but not “working”.

Does your full 4-component ID match

[8086:06f0:8086:000]

I’m not sure what the wl module is. Can you show us the output of modinfo wl?

This system has [8086:a370:8086:4030] and does not list a wl` module:

~% sudo lspci -nn -s 00:14.3 -v
00:14.3 Network controller [0280]: Intel Corporation Cannon Lake PCH CNVi WiFi [8086:a370] (rev 10)
	DeviceName: Onboard - Ethernet
	Subsystem: Intel Corporation Device [8086:4030]
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at d1414000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
	Capabilities: [100] Null
	Capabilities: [14c] Latency Tolerance Reporting
	Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

The working laptop I have has a 8086:a370:8086:4070 and no wl kernel module (which does not exist in the fedora repos as far as I can tell). It is an AX201. I do not remember which fedora was first used but it has always worked since it was obtained in 2020. It came with ubuntu pre-installed from the manufacturer though I never ran it that way.

Currently I am in learning mode trying to figure out how to run kubernetes on the bare metal with kubevirt where the desktop will be a VM. From there use it as a portable, self-contained lab. The lab is to be fully functional even when running disconnected from external networks.

Here you have it:

root@df-laptop:~# modinfo wl
filename:       /lib/modules/6.6.9-200.fc39.x86_64/extra/wl/wl.ko.xz
license:        MIXED/Proprietary
rhelversion:    9.99
alias:          pci:v*d*sv*sd*bc02sc80i*
depends:        cfg80211
retpoline:      Y
name:           wl
vermagic:       6.6.9-200.fc39.x86_64 SMP preempt mod_unload 
sig_id:         PKCS#7
signer:         df-laptop-896680055
sig_key:        79:37:F8:64:42:C6:01:29:2E:75:8D:8C:75:73:0A:44:41:33:DB:11
sig_hashalgo:   sha256
signature:      A0:CC:8A:80:8B:33:9F:D8:07:F1:DD:28:84:78:F9:A1:C3:0F:52:F9:
                57:73:6D:46:50:A2:02:88:F5:AE:D7:D7:E7:38:6E:68:31:43:46:5B:
                9F:BC:49:CA:36:80:92:90:EA:00:0C:A7:29:4C:E2:62:AD:2E:BD:A6:
                52:32:52:37:4A:89:A5:38:77:41:D1:5A:4F:12:47:59:04:AE:A5:CE:
                B0:EB:45:7E:79:38:3E:B3:75:52:DB:DF:9C:80:F2:69:AB:B2:47:C0:
                04:9A:0F:29:3F:6E:4B:CC:0C:72:D2:E2:DC:45:20:F1:74:E2:6F:0B:
                0F:EA:9F:C8:18:9E:79:1A:A1:1A:73:9A:E7:20:92:66:D0:FE:D9:1A:
                05:55:4E:86:13:BF:AC:CA:FE:31:A0:BB:12:65:0B:A9:31:C3:CA:8C:
                44:FA:9D:D8:3F:E5:ED:A2:94:80:7A:9D:C2:97:95:5A:A1:77:A7:51:
                6E:4F:E2:D8:70:B7:EA:72:74:97:03:37:4F:4C:70:AA:03:8A:86:F6:
                CC:7A:4D:59:17:CB:2D:8D:F5:B6:66:41:A5:9B:AE:2D:7F:68:64:E2:
                93:E7:9A:58:57:B9:D4:46:5A:EB:0F:3D:F4:5B:DA:E8:BE:F0:2E:A0:
                47:CD:AF:21:AF:37:17:FF:27:FC:0F:50:8B:0F:50:2A:FC:A4:B7:70:
                E2:DB:F1:01:C0:F3:6E:CF:3F:CA:7D:8D:18:AF:A6:20:74:3D:96:EA:
                C5:25:DC:21:E6:70:5F:77:B4:60:1C:DE:8C:78:49:C2:DC:6E:0B:5C:
                34:8D:9E:A0:1D:56:FC:1E:C4:33:1F:05:37:77:42:6B:B6:47:E7:0B:
                34:20:82:83:72:A7:2E:16:6F:B4:5D:EB:26:BF:A0:DE:AF:9C:D7:1E:
                BE:D2:E1:A1:2F:0A:9E:42:03:46:3E:04:20:5C:EB:53:13:12:8B:31:
                8C:2B:F4:81:68:44:BE:C4:EA:61:2B:FC:38:83:84:7A:E8:EB:EA:32:
                2F:E6:7A:32:74:AF:07:32:6E:1B:FB:5D:F0:EE:50:AC:DC:47:83:50:
                96:E4:11:D7:01:6D:09:77:A7:10:5E:4D:CA:AB:29:57:7B:48:28:DB:
                28:24:5B:0B:00:EE:B4:B8:4D:9C:0C:AD:46:31:46:46:AB:4C:96:EB:
                3B:61:E6:C8:74:89:FD:35:53:4D:E4:A3:0D:2A:D6:D8:C5:47:E5:57:
                71:77:C9:CF:73:FF:A0:4C:8A:6F:BA:0F:FF:5E:A9:F6:5A:B9:84:67:
                C9:5C:33:CB:95:C3:4D:66:09:62:5B:2E:DF:64:20:3E:D2:62:86:89:
                24:59:4E:C9:D3:A8:83:B5:A2:06:AB:06
parm:           passivemode:int
parm:           wl_txq_thresh:int
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           nompc:int
parm:           intf_name:string

I believe mine is not an AX201 (in the name), but a CNVi, so it is not the same hardware (as the VEN,DEV,SSV,SSD also shows). Maybe do the lspci for yours to confirm the name is not the same.

I believe the wl module is the one for use with broadcom chipsets. That one probably should not load for use with an intel chipset, and I would not have it installed unless there was a broadcom wifi adapter in the system.

Removal would probably be as simple as dnf remove broadcom-wl akmod-wl kmod-wl-*.
The kmod-wl packages are built by akmods from the akmod-wl package and those actually contain the wl driver module (locally compiled).

1 Like

I am using an USB AC600 dual band WiFi adapter for the time being, when I need to use some WiFi… Maybe that uses a Broadcom chip?

Do you think it should be removed?

If I try to modprobe it, then it complains about key not being valid… It does not appear in the lsmod, but I do not have that USB adapter plugged at the moment.

Interesting, why is wl.ko attached to an Intel wifi adapter? Also interesting that the rpmfusion packages do not package the wl.ko but a way to build it locally. I’ll have to remember that when looking for kernel modules in the future. Thanks!

Since broadcom chipsets use proprietary drivers and are not supported by fedora I would strongly suggest that you obtain a wifi dongle that uses a supported chipset (intel or the like) so you could remove the proprietary drivers that seem to be needed for the external dongle.

If the internal wifi is not supported then maybe simply replacing that card would handle both problems. The wifi cards used in laptops are mostly M.2 design and easily replaced.

1 Like

I am slowly catching on. The Intel CPU has built-in wifi support `PCH CNVi WiFi’. Then there is a M.2 card on the motherboard suppling the radios and other phy requirements CNVi. In mine is an AX201 companion rf module

@davidfc has [8086:06f0:8086:0000] which @gnwiii points to and is shown to be an AX201 as well.

blacklist the kernel module from broadcom-wl, power cycle, and see if the AX201 works would be something I would try.

1 Like

Newer Intel chipsets split wifi between the IP protocol support in the chipset (CNVi) and radio, usually in a socketed CNVi card. Quotiing Intel’s discussion of differences between AC-9260 and AC-9560:

Depending on the design, a M.2 socket may support both the CNVi and standard M.2 Key A for Intel® Wireless-AC 9260.

In contrast, the Intel® Wireless-AC 9260 does not support integrated Intel® Wireless-AC solution. For this reason, we recommend contacting the motherboard manufacturer before installing/replacing an Intel® Wireless Adapter to prevent system conflicts.